PKGBUILDs/extra/ceph/no-neon.patch
2016-09-10 17:34:45 +00:00

213 lines
5.4 KiB
Diff

diff -urN a/configure b/configure
--- a/configure 2016-06-14 05:44:54.000000000 -0600
+++ b/configure 2016-09-10 11:30:50.025304378 -0600
@@ -21627,204 +21627,11 @@
fi
-# Find supported SIMD / NEON / SSE extensions supported by the compiler
+HAVE_NEON_TRUE='#'
+HAVE_NEON_FALSE=
-
-
- case $target_cpu in
- arm*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -mfpu=neon" >&5
-$as_echo_n "checking whether C compiler accepts -mfpu=neon... " >&6; }
-if ${ax_cv_check_cflags___mfpu_neon+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -mfpu=neon"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___mfpu_neon=yes
-else
- ax_cv_check_cflags___mfpu_neon=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___mfpu_neon" >&5
-$as_echo "$ax_cv_check_cflags___mfpu_neon" >&6; }
-if test x"$ax_cv_check_cflags___mfpu_neon" = xyes; then :
- ax_cv_support_neon_ext=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
- ARM_NEON_FLAGS="-mfpu=neon -DARM_NEON"
-
- ARM_FLAGS="$ARM_FLAGS $ARM_NEON_FLAGS"
-
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
-
- fi
- ;;
- aarch64*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a" >&5
-$as_echo_n "checking whether C compiler accepts -march=armv8-a... " >&6; }
-if ${ax_cv_check_cflags___march_armv8_a+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -march=armv8-a"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___march_armv8_a=yes
-else
- ax_cv_check_cflags___march_armv8_a=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_a" >&5
-$as_echo "$ax_cv_check_cflags___march_armv8_a" >&6; }
-if test x"$ax_cv_check_cflags___march_armv8_a" = xyes; then :
- ax_cv_support_armv8=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_armv8" = x"yes"; then
- ARM_ARCH_FLAGS="-march=armv8-a"
- ARM_DEFINE_FLAGS="-DARCH_AARCH64"
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+simd" >&5
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+simd... " >&6; }
-if ${ax_cv_check_cflags___march_armv8_apsimd+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -march=armv8-a+simd"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___march_armv8_apsimd=yes
-else
- ax_cv_check_cflags___march_armv8_apsimd=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_apsimd" >&5
-$as_echo "$ax_cv_check_cflags___march_armv8_apsimd" >&6; }
-if test x"$ax_cv_check_cflags___march_armv8_apsimd" = xyes; then :
- ax_cv_support_neon_ext=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
- ARM_ARCH_FLAGS="$ARM_ARCH_FLAGS+simd"
- ARM_DEFINE_FLAGS="$ARM_DEFINE_FLAGS -DARM_NEON"
- ARM_NEON_FLAGS="-march=armv8-a+simd -DARCH_AARCH64 -DARM_NEON"
-
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
-
-
- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+crc" >&5
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+crc... " >&6; }
-if ${ax_cv_check_cflags___march_armv8_apcrc+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -march=armv8-a+crc"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___march_armv8_apcrc=yes
-else
- ax_cv_check_cflags___march_armv8_apcrc=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_apcrc" >&5
-$as_echo "$ax_cv_check_cflags___march_armv8_apcrc" >&6; }
-if test x"$ax_cv_check_cflags___march_armv8_apcrc" = xyes; then :
- ax_cv_support_crc_ext=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_crc_ext" = x"yes"; then
- ARM_ARCH_FLAGS="$ARM_ARCH_FLAGS+crc"
- ARM_CRC_FLAGS="-march=armv8-a+crc -DARCH_AARCH64"
-
-$as_echo "#define HAVE_ARMV8_CRC /**/" >>confdefs.h
-
-
- fi
- ARM_FLAGS="$ARM_ARCH_FLAGS $ARM_DEFINE_FLAGS"
- ;;
- esac
-
-
-
- if test "x$ax_cv_support_neon_ext" = "xyes"; then
- HAVE_NEON_TRUE=
- HAVE_NEON_FALSE='#'
-else
- HAVE_NEON_TRUE='#'
- HAVE_NEON_FALSE=
-fi
-
- if test "x$ax_cv_support_crc_ext" = "xyes"; then
- HAVE_ARMV8_CRC_TRUE=
- HAVE_ARMV8_CRC_FALSE='#'
-else
- HAVE_ARMV8_CRC_TRUE='#'
- HAVE_ARMV8_CRC_FALSE=
-fi
+HAVE_ARMV8_CRC_TRUE='#'
+HAVE_ARMV8_CRC_FALSE=