mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
26 lines
1.3 KiB
Diff
26 lines
1.3 KiB
Diff
diff --git a/third_party/blink/renderer/core/xml/xslt_processor.h b/third_party/blink/renderer/core/xml/xslt_processor.h
|
|
index d53835e9675793..2eaea31ed29b90 100644
|
|
--- a/third_party/blink/renderer/core/xml/xslt_processor.h
|
|
+++ b/third_party/blink/renderer/core/xml/xslt_processor.h
|
|
@@ -77,7 +77,7 @@ class XSLTProcessor final : public ScriptWrappable {
|
|
|
|
void reset();
|
|
|
|
- static void ParseErrorFunc(void* user_data, xmlError*);
|
|
+ static void ParseErrorFunc(void* user_data, const xmlError*);
|
|
static void GenericErrorFunc(void* user_data, const char* msg, ...);
|
|
|
|
// Only for libXSLT callbacks
|
|
diff --git a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
|
|
index 133e0b3355d2f0..f424077089da87 100644
|
|
--- a/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
|
|
+++ b/third_party/blink/renderer/core/xml/xslt_processor_libxslt.cc
|
|
@@ -66,7 +66,7 @@ void XSLTProcessor::GenericErrorFunc(void*, const char*, ...) {
|
|
// It would be nice to do something with this error message.
|
|
}
|
|
|
|
-void XSLTProcessor::ParseErrorFunc(void* user_data, xmlError* error) {
|
|
+void XSLTProcessor::ParseErrorFunc(void* user_data, const xmlError* error) {
|
|
FrameConsole* console = static_cast<FrameConsole*>(user_data);
|
|
if (!console)
|
|
return;
|