mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
13 lines
523 B
Diff
13 lines
523 B
Diff
diff --git a/libavutil/hwcontext_vaapi.c b/libavutil/hwcontext_vaapi.c
|
|
index 29fc8bd648..1f85fac7f4 100644
|
|
--- a/libavutil/hwcontext_vaapi.c
|
|
+++ b/libavutil/hwcontext_vaapi.c
|
|
@@ -1203,7 +1203,7 @@ static int vaapi_map_from_drm(AVHWFramesContext *src_fc, AVFrame *dst,
|
|
|
|
if (!use_prime2 || vas != VA_STATUS_SUCCESS) {
|
|
int k;
|
|
- unsigned long buffer_handle;
|
|
+ uintptr_t buffer_handle;
|
|
VASurfaceAttribExternalBuffers buffer_desc;
|
|
VASurfaceAttrib buffer_attrs[2] = {
|
|
{
|