PKGBUILDs/alarm/kodi-rpi-git/0001-mcpu-cortex-a72-for-RPi4-application-to-ffmpeg.patch
graysky 0926d17669 alarm/kodi-rpi-git to 19.0b2.56808.0f75c91014-4
Properly set cortex-a72 optimizations for this package, see comment
in 0000-use-mcpu-avoiding-march-and-mtune.patch for more details.

Should be totally fine in doing so since this only RPi 4 can actually
make use of the HW decoding intended for v19 once it goes final and the
patchset is gets merged into ffmpeg (at some point).

In addition to that, fix a small bug in kodi.service, for details see:
909f274d6e
2020-12-14 09:28:48 -05:00

27 lines
1.2 KiB
Diff

From 666fd7f69f684d7dd23b1ee665b0902e29953b76 Mon Sep 17 00:00:00 2001
From: graysky <graysky@archlinux.us>
Date: Sat, 12 Dec 2020 09:29:51 -0500
Subject: [PATCH] mcpu=cortex-a72 for RPi4 application to ffmpeg
Get build system to patch ffmpeg source removing the -march= flag
---
cmake/modules/FindFFMPEG.cmake | 1 +
1 file changed, 1 insertion(+)
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
index 9ce807c..a18b21c 100644
--- a/cmake/modules/FindFFMPEG.cmake
+++ b/cmake/modules/FindFFMPEG.cmake
@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
<SOURCE_DIR> &&
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
echo "########################################## patched ffmpeg ##############################"
)
--
2.29.2