mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
24 lines
960 B
Diff
24 lines
960 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Sat, 6 Nov 2021 22:42:06 +0100
|
|
Subject: [PATCH] compiler: Use wasm-ld for wasm targets
|
|
|
|
We don't ship rust-lld.
|
|
---
|
|
compiler/rustc_target/src/spec/wasm_base.rs | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
|
index 71aa279144bb..6ea5b5fa602c 100644
|
|
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
|
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
|
@@ -99,8 +99,7 @@ pub fn options() -> TargetOptions {
|
|
// arguments just yet
|
|
limit_rdylib_exports: false,
|
|
|
|
- // we use the LLD shipped with the Rust toolchain by default
|
|
- linker: Some("rust-lld".to_owned()),
|
|
+ linker: Some("wasm-ld".to_owned()),
|
|
lld_flavor: LldFlavor::Wasm,
|
|
linker_is_gnu: false,
|
|
|