mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
65 lines
2.8 KiB
Diff
65 lines
2.8 KiB
Diff
From a8e03faa56efeacd50fe8b64bda65ac17c83ea8e Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sun, 6 Mar 2016 20:26:53 -0700
|
|
Subject: [PATCH 1/2] system ffmpeg fixes
|
|
|
|
---
|
|
media/ffmpeg/ffmpeg_common.h | 5 -----
|
|
media/filters/ffmpeg_demuxer.cc | 18 ------------------
|
|
2 files changed, 23 deletions(-)
|
|
|
|
diff --git a/media/ffmpeg/ffmpeg_common.h b/media/ffmpeg/ffmpeg_common.h
|
|
index 55e3ab7..0ec595c 100644
|
|
--- a/media/ffmpeg/ffmpeg_common.h
|
|
+++ b/media/ffmpeg/ffmpeg_common.h
|
|
@@ -21,10 +21,6 @@
|
|
|
|
// Include FFmpeg header files.
|
|
extern "C" {
|
|
-// Disable deprecated features which result in spammy compile warnings. This
|
|
-// list of defines must mirror those in the 'defines' section of BUILD.gn file &
|
|
-// ffmpeg.gyp file or the headers below will generate different structures!
|
|
-#define FF_API_CONVERGENCE_DURATION 0
|
|
// Upstream libavcodec/utils.c still uses the deprecated
|
|
// av_dup_packet(), causing deprecation warnings.
|
|
// The normal fix for such things is to disable the feature as below,
|
|
@@ -38,7 +34,6 @@ extern "C" {
|
|
MSVC_PUSH_DISABLE_WARNING(4244);
|
|
#include <libavcodec/avcodec.h>
|
|
#include <libavformat/avformat.h>
|
|
-#include <libavformat/internal.h>
|
|
#include <libavformat/avio.h>
|
|
#include <libavutil/avutil.h>
|
|
#include <libavutil/imgutils.h>
|
|
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
|
index 20adebe..166cea6 100644
|
|
--- a/media/filters/ffmpeg_demuxer.cc
|
|
+++ b/media/filters/ffmpeg_demuxer.cc
|
|
@@ -1034,24 +1034,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
|
// If no estimate is found, the stream entry will be kInfiniteDuration().
|
|
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
|
kInfiniteDuration());
|
|
- const AVFormatInternal* internal = format_context->internal;
|
|
- if (internal && internal->packet_buffer &&
|
|
- format_context->start_time != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
|
- struct AVPacketList* packet_buffer = internal->packet_buffer;
|
|
- while (packet_buffer != internal->packet_buffer_end) {
|
|
- DCHECK_LT(static_cast<size_t>(packet_buffer->pkt.stream_index),
|
|
- start_time_estimates.size());
|
|
- const AVStream* stream =
|
|
- format_context->streams[packet_buffer->pkt.stream_index];
|
|
- if (packet_buffer->pkt.pts != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
|
- const base::TimeDelta packet_pts =
|
|
- ConvertFromTimeBase(stream->time_base, packet_buffer->pkt.pts);
|
|
- if (packet_pts < start_time_estimates[stream->index])
|
|
- start_time_estimates[stream->index] = packet_pts;
|
|
- }
|
|
- packet_buffer = packet_buffer->next;
|
|
- }
|
|
- }
|
|
|
|
AVStream* audio_stream = NULL;
|
|
AudioDecoderConfig audio_config;
|
|
--
|
|
2.8.0
|
|
|