mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
430d61689f
Add missing patch
27 lines
934 B
Diff
27 lines
934 B
Diff
From 46cce667db4dd477556d30137515c839f4efb0b1 Mon Sep 17 00:00:00 2001
|
|
From: graysky <graysky@archlinux.us>
|
|
Date: Sat, 11 Sep 2021 13:29:39 -0400
|
|
Subject: [PATCH] Revert "drm/vc4: hdmi: Remove the DDC probing for status
|
|
detection"
|
|
|
|
This reverts commit 17a554471341cabeb583feb02f04eb785d7d9bf8.
|
|
---
|
|
drivers/gpu/drm/vc4/vc4_hdmi.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/drivers/gpu/drm/vc4/vc4_hdmi.c b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
|
index cc1a05df6195..9e86970d5afc 100644
|
|
--- a/drivers/gpu/drm/vc4/vc4_hdmi.c
|
|
+++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
|
|
@@ -185,6 +185,8 @@ vc4_hdmi_connector_detect(struct drm_connector *connector, bool force)
|
|
if (gpio_get_value_cansleep(vc4_hdmi->hpd_gpio) ^
|
|
vc4_hdmi->hpd_active_low)
|
|
connected = true;
|
|
+ } else if (drm_probe_ddc(vc4_hdmi->ddc)) {
|
|
+ connected = true;
|
|
} else if (HDMI_READ(HDMI_HOTPLUG) & VC4_HDMI_HOTPLUG_CONNECTED) {
|
|
connected = true;
|
|
}
|
|
--
|
|
2.33.0
|
|
|