mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
31 lines
703 B
Diff
31 lines
703 B
Diff
diff -ruN a/os_dep/linux/os_intfs.c b/os_dep/linux/os_intfs.c
|
|
--- a/os_dep/linux/os_intfs.c 2012-11-05 00:42:45.000000000 -0700
|
|
+++ b/os_dep/linux/os_intfs.c 2013-07-11 16:28:42.000000000 -0600
|
|
@@ -255,6 +255,19 @@
|
|
static struct proc_dir_entry *rtw_proc = NULL;
|
|
static int rtw_proc_cnt = 0;
|
|
|
|
+#ifndef create_proc_entry
|
|
+/* dummy routines */
|
|
+void rtw_proc_remove_one(struct net_device *dev)
|
|
+{
|
|
+}
|
|
+
|
|
+void rtw_proc_init_one(struct net_device *dev)
|
|
+{
|
|
+}
|
|
+
|
|
+#else /* create_proc_entry not defined */
|
|
+
|
|
+
|
|
void rtw_proc_init_one(struct net_device *dev)
|
|
{
|
|
struct proc_dir_entry *dir_dev = NULL;
|
|
@@ -525,6 +538,7 @@
|
|
}
|
|
}
|
|
#endif
|
|
+#endif
|
|
|
|
uint loadparam( _adapter *padapter, _nic_hdl pnetdev)
|
|
{
|