PKGBUILDs/core/linux-armv5-rc/0009-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch
2020-02-12 04:00:15 +00:00

33 lines
943 B
Diff

From ce1f44a77f67dbf89257561c8e2f486fbf27acf6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:45:51 -0700
Subject: [PATCH 9/9] Revert "vfs,mm: fix a dead loop in
truncate_inode_pages_range()"
This reverts commit c2a9737f45e27d8263ff9643f994bda9bac0b944.
This causes the kernel to not be able to read beyond 8TB on a single
device.
---
mm/filemap.c | 4 ----
1 file changed, 4 deletions(-)
diff --git a/mm/filemap.c b/mm/filemap.c
index 1784478270e1..50fac462508f 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -1999,10 +1999,6 @@ static ssize_t generic_file_buffered_read(struct kiocb *iocb,
unsigned int prev_offset;
int error = 0;
- if (unlikely(*ppos >= inode->i_sb->s_maxbytes))
- return 0;
- iov_iter_truncate(iter, inode->i_sb->s_maxbytes);
-
index = *ppos >> PAGE_SHIFT;
prev_index = ra->prev_pos >> PAGE_SHIFT;
prev_offset = ra->prev_pos & (PAGE_SIZE-1);
--
2.25.0