mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
23 lines
769 B
Diff
23 lines
769 B
Diff
From 2ca83eac52092eb297b7f3cee3d6057377e57c67 Mon Sep 17 00:00:00 2001
|
|
From: Peter Hull <peterhull90@gmail.com>
|
|
Date: Mon, 25 Jan 2016 09:21:13 +0000
|
|
Subject: [PATCH] Added -msse2 to compile flags for all sources. Under GCC 5
|
|
it's needed, otherwise compiling UArray_math.c fails.
|
|
|
|
---
|
|
CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 7e3a3bc..e6d19e5 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -39,7 +39,7 @@ IF(CMAKE_COMPILER_IS_GNUCC)
|
|
SET(CMAKE_BUILD_TYPE_DebugFast)
|
|
SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
|
|
SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
|
|
-
|
|
+ SET(CMAKE_C_FLAGS "-msse2")
|
|
if(NOT CMAKE_BUILD_TYPE)
|
|
SET(CMAKE_BUILD_TYPE "DebugFast")
|
|
endif(NOT CMAKE_BUILD_TYPE)
|