mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
96 lines
2.8 KiB
Diff
96 lines
2.8 KiB
Diff
From adbe2263370aaa90bafa5d1d1da043bea63b5118 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
|
Date: Mon, 13 Aug 2018 13:41:14 +0200
|
|
Subject: [PATCH 16/16] Revert "build: add --with-jansson"
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This reverts commit 12b34f094e2f1c7f414f4bb8f880a9d65c8fcd85.
|
|
|
|
Jansson cannot parse QEMU's quirky JSON.
|
|
Revert back to yajl.
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1614569
|
|
|
|
Conflicts:
|
|
configure.ac:
|
|
Commit 8aa85e0b introduced LIBVIRT_*_LIBISCSI macros.
|
|
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
|
|
---
|
|
configure.ac | 6 +++---
|
|
m4/virt-jansson.m4 | 29 -----------------------------
|
|
2 files changed, 3 insertions(+), 32 deletions(-)
|
|
delete mode 100644 m4/virt-jansson.m4
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c6287f656a..c668630a79 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -250,7 +250,7 @@ LIBVIRT_ARG_FIREWALLD
|
|
LIBVIRT_ARG_FUSE
|
|
LIBVIRT_ARG_GLUSTER
|
|
LIBVIRT_ARG_HAL
|
|
-LIBVIRT_ARG_JANSSON
|
|
+LIBVIRT_ARG_LIBISCSI
|
|
LIBVIRT_ARG_LIBPCAP
|
|
LIBVIRT_ARG_LIBSSH
|
|
LIBVIRT_ARG_LIBXML
|
|
@@ -291,7 +291,7 @@ LIBVIRT_CHECK_FUSE
|
|
LIBVIRT_CHECK_GLUSTER
|
|
LIBVIRT_CHECK_GNUTLS
|
|
LIBVIRT_CHECK_HAL
|
|
-LIBVIRT_CHECK_JANSSON
|
|
+LIBVIRT_CHECK_LIBISCSI
|
|
LIBVIRT_CHECK_LIBNL
|
|
LIBVIRT_CHECK_LIBPARTED
|
|
LIBVIRT_CHECK_LIBPCAP
|
|
@@ -972,7 +972,7 @@ LIBVIRT_RESULT_FUSE
|
|
LIBVIRT_RESULT_GLUSTER
|
|
LIBVIRT_RESULT_GNUTLS
|
|
LIBVIRT_RESULT_HAL
|
|
-LIBVIRT_RESULT_JANSSON
|
|
+LIBVIRT_RESULT_LIBISCSI
|
|
LIBVIRT_RESULT_LIBNL
|
|
LIBVIRT_RESULT_LIBPCAP
|
|
LIBVIRT_RESULT_LIBSSH
|
|
diff --git a/m4/virt-jansson.m4 b/m4/virt-jansson.m4
|
|
deleted file mode 100644
|
|
index 206d6a5ced..0000000000
|
|
--- a/m4/virt-jansson.m4
|
|
+++ /dev/null
|
|
@@ -1,29 +0,0 @@
|
|
-dnl The jansson library
|
|
-dnl
|
|
-dnl This library is free software; you can redistribute it and/or
|
|
-dnl modify it under the terms of the GNU Lesser General Public
|
|
-dnl License as published by the Free Software Foundation; either
|
|
-dnl version 2.1 of the License, or (at your option) any later version.
|
|
-dnl
|
|
-dnl This library is distributed in the hope that it will be useful,
|
|
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
-dnl Lesser General Public License for more details.
|
|
-dnl
|
|
-dnl You should have received a copy of the GNU Lesser General Public
|
|
-dnl License along with this library. If not, see
|
|
-dnl <http://www.gnu.org/licenses/>.
|
|
-dnl
|
|
-
|
|
-AC_DEFUN([LIBVIRT_ARG_JANSSON],[
|
|
- LIBVIRT_ARG_WITH_FEATURE([JANSSON], [jansson], [check])
|
|
-])
|
|
-
|
|
-AC_DEFUN([LIBVIRT_CHECK_JANSSON],[
|
|
- dnl Jansson http://www.digip.org/jansson/
|
|
- LIBVIRT_CHECK_PKG([JANSSON], [jansson], [2.5])
|
|
-])
|
|
-
|
|
-AC_DEFUN([LIBVIRT_RESULT_JANSSON],[
|
|
- LIBVIRT_RESULT_LIB([JANSSON])
|
|
-])
|
|
--
|
|
2.18.0
|
|
|