PKGBUILDs/extra/denyhosts/log-injection-fix.diff
2009-10-09 21:23:22 -05:00

11 lines
717 B
Diff

--- DenyHosts-2.6/DenyHosts/regex-old.py 2008-01-29 03:07:51.000000000 +0100
+++ DenyHosts-2.6/DenyHosts/regex.py 2008-01-29 03:07:53.000000000 +0100
@@ -17,7 +17,7 @@
FAILED_ENTRY_REGEX4 = re.compile(r"""Authentication failure for (?P<user>.*) .*from (?P<host>.*)""")
-FAILED_ENTRY_REGEX5 = re.compile(r"""User (?P<user>.*) .*from (?P<host>.*) not allowed because none of user's groups are listed in AllowGroups""")
+FAILED_ENTRY_REGEX5 = re.compile(r"""User (?P<user>.*) .*from (?P<host>.*) not allowed because none of user's groups are listed in AllowGroups$""")
FAILED_ENTRY_REGEX6 = re.compile(r"""Did not receive identification string .*from (::ffff:)?(?P<host>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})""")