PKGBUILDs/extra/mplayer/0001-demux_gif-declare-missing-PrintGifError.patch
2013-08-01 12:50:00 +00:00

35 lines
1,003 B
Diff

From 5194f95d39ffbb0a4a7b027d8f1b084436feb22c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <b@bpiotrowski.pl>
Date: Sun, 14 Jul 2013 10:51:11 +0200
Subject: [PATCH] demux_gif: declare missing PrintGifError
Apparently it has been removed from newer Giflib releases.
---
libmpdemux/demux_gif.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/libmpdemux/demux_gif.c b/libmpdemux/demux_gif.c
index eee7a85..3d761c0 100644
--- a/libmpdemux/demux_gif.c
+++ b/libmpdemux/demux_gif.c
@@ -44,6 +44,16 @@ typedef struct {
#define GIF_SIGNATURE (('G' << 16) | ('I' << 8) | 'F')
+static void PrintGifError(void)
+{
+ char *Err = GifErrorString();
+
+ if (Err != NULL)
+ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
+ else
+ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
+}
+
#ifndef CONFIG_GIF_TVT_HACK
// not supported by certain versions of the library
static int my_read_gif(GifFileType *gif, uint8_t *buf, int len)
--
1.8.3.2