mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
44 lines
1.9 KiB
Diff
44 lines
1.9 KiB
Diff
From 8d1c8bd746a6a14dec7470f93f843bcb0699f4b8 Mon Sep 17 00:00:00 2001
|
|
From: David Herrmann <dh.herrmann@gmail.com>
|
|
Date: Fri, 12 Dec 2014 09:52:06 +0100
|
|
Subject: [PATCH] journal: fix dangling 'else' ambiguity
|
|
|
|
Rework the sd-journal iterators to avoid dangling 'else' ambiguity. For a
|
|
detailed explanation, see:
|
|
|
|
commit bff686e2a981ccd0888cdf1981977d24320f1770
|
|
Author: David Herrmann <dh.herrmann@gmail.com>
|
|
Date: Fri Dec 12 09:43:54 2014 +0100
|
|
|
|
hwdb: fix dangling 'else' ambuguity
|
|
---
|
|
src/systemd/sd-journal.h | 10 ++++++----
|
|
1 file changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/src/systemd/sd-journal.h b/src/systemd/sd-journal.h
|
|
index eb24372..00237a2 100644
|
|
--- a/src/systemd/sd-journal.h
|
|
+++ b/src/systemd/sd-journal.h
|
|
@@ -138,13 +138,15 @@ int sd_journal_reliable_fd(sd_journal *j);
|
|
int sd_journal_get_catalog(sd_journal *j, char **text);
|
|
int sd_journal_get_catalog_for_message_id(sd_id128_t id, char **text);
|
|
|
|
+/* the inverse condition avoids ambiguity of danling 'else' after the macro */
|
|
#define SD_JOURNAL_FOREACH(j) \
|
|
- if (sd_journal_seek_head(j) >= 0) \
|
|
- while (sd_journal_next(j) > 0)
|
|
+ if (sd_journal_seek_head(j) < 0) { } \
|
|
+ else while (sd_journal_next(j) > 0)
|
|
|
|
+/* the inverse condition avoids ambiguity of danling 'else' after the macro */
|
|
#define SD_JOURNAL_FOREACH_BACKWARDS(j) \
|
|
- if (sd_journal_seek_tail(j) >= 0) \
|
|
- while (sd_journal_previous(j) > 0)
|
|
+ if (sd_journal_seek_tail(j) < 0) { } \
|
|
+ else while (sd_journal_previous(j) > 0)
|
|
|
|
#define SD_JOURNAL_FOREACH_DATA(j, data, l) \
|
|
for (sd_journal_restart_data(j); sd_journal_enumerate_data((j), &(data), &(l)) > 0; )
|
|
--
|
|
2.3.0
|
|
|