mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
25 lines
719 B
Diff
25 lines
719 B
Diff
From 9c4d9d826a6f40f199c526afd5ec168d5d088591 Mon Sep 17 00:00:00 2001
|
|
From: Martin Braun <martin.braun@ettus.com>
|
|
Date: Fri, 29 Jan 2021 12:23:50 +0100
|
|
Subject: [PATCH] lib: Fix missing includes in rpc.hpp
|
|
|
|
---
|
|
host/lib/include/uhdlib/utils/rpc.hpp | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/host/lib/include/uhdlib/utils/rpc.hpp b/host/lib/include/uhdlib/utils/rpc.hpp
|
|
index e87a2ee32..ca89c1054 100644
|
|
--- a/host/lib/include/uhdlib/utils/rpc.hpp
|
|
+++ b/host/lib/include/uhdlib/utils/rpc.hpp
|
|
@@ -12,7 +12,11 @@
|
|
#include <rpc/client.h>
|
|
#include <rpc/rpc_error.h>
|
|
#include <boost/format.hpp>
|
|
+#include <chrono>
|
|
#include <memory>
|
|
+#include <mutex>
|
|
+#include <string>
|
|
+#include <thread>
|
|
|
|
namespace {
|
|
|