PKGBUILDs/extra/doxygen/0001-Partial-revert-of-commit-080a465b1321.patch
2015-12-12 03:33:21 +00:00

34 lines
904 B
Diff

From 7725d0a48aee2928dc0544ccbb0aa79ddb3a74d4 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Wed, 9 Dec 2015 18:16:09 +0200
Subject: [PATCH] Partial revert of commit 080a465b1321
Fixes generation of libstd++ man pages.
https://bugzilla.gnome.org/show_bug.cgi?id=759241
---
src/util.cpp | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/src/util.cpp b/src/util.cpp
index 3ee7ae5..0bf9940 100644
--- a/src/util.cpp
+++ b/src/util.cpp
@@ -1741,11 +1741,9 @@ nextChar:
}
else if (i>0 &&
(
- (s.at(i-1)==')' && isId(c)) // ")id" -> ") id"
+ (s.at(i-1)==')' && isId(c))
||
- (c=='\'' && s.at(i-1)==' ') // "'id" -> "' id"
- ||
- (i>1 && s.at(i-2)==' ' && s.at(i-1)==' ') // " id" -> " id"
+ (c=='\'' && s.at(i-1)==' ')
)
)
{
--
2.6.3