PKGBUILDs/core/mkinitcpio/0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch
2017-09-10 00:47:51 +00:00

32 lines
1 KiB
Diff

From 504340f5d19ab301768b8db5199d3d71f2abbfcb Mon Sep 17 00:00:00 2001
From: Dave Reisner <dreisner@archlinux.org>
Date: Mon, 21 Aug 2017 21:33:22 -0400
Subject: [PATCH 1/2] make ldd parsing compatible with upstream glibc changes
https://sourceware.org/git/?p=glibc.git;a=commit;h=eedca9772e99c72ab4c3c34e43cc764250aa3e3c
---
functions | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/functions b/functions
index 4afc902..7288c44 100644
--- a/functions
+++ b/functions
@@ -587,10 +587,10 @@ add_binary() {
! lddout=$(ldd "$binary" 2>/dev/null) && return 0
# resolve sodeps
- regex='(/.+) \(0x[a-fA-F0-9]+\)'
- while read line; do
+ regex='^(|.+ )(/.+) \(0x[a-fA-F0-9]+\)'
+ while read -r line; do
if [[ $line =~ $regex ]]; then
- sodep=${BASH_REMATCH[1]}
+ sodep=${BASH_REMATCH[2]}
elif [[ $line = *'not found' ]]; then
error "binary dependency \`%s' not found for \`%s'" "${line%% *}" "$1"
(( ++_builderrors ))
--
2.14.1