mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
15 lines
609 B
Diff
15 lines
609 B
Diff
diff -Naur glib-1.2.10.orig/glib.h glib-1.2.10/glib.h
|
|
--- glib-1.2.10.orig/glib.h 2001-02-27 04:44:38.000000000 +0100
|
|
+++ glib-1.2.10/glib.h 2004-05-27 15:50:32.436527848 +0200
|
|
@@ -271,8 +271,10 @@
|
|
|
|
/* Wrap the gcc __PRETTY_FUNCTION__ and __FUNCTION__ variables with
|
|
* macros, so we can refer to them as strings unconditionally.
|
|
+ *
|
|
+ * Unfortunately these are _not_ treated as strings anymore in GCC3.4.
|
|
*/
|
|
-#ifdef __GNUC__
|
|
+#if defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ < 4)
|
|
#define G_GNUC_FUNCTION __FUNCTION__
|
|
#define G_GNUC_PRETTY_FUNCTION __PRETTY_FUNCTION__
|
|
#else /* !__GNUC__ */
|