mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
From 2eac3aeb98fca0e6c13aaaff481861c5ef679e68 Mon Sep 17 00:00:00 2001
|
|
From: Konstantin Tokarev <annulen@yandex.ru>
|
|
Date: Tue, 8 Oct 2019 01:20:22 +0300
|
|
Subject: [PATCH] Import QtWebKit commit
|
|
5e53102492e5ce85bda2657468f1369a0173c2ce
|
|
|
|
Change-Id: Id71d7c7f5eafe58f7bd8c46a2a07fd0bad015628
|
|
Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
|
|
|
|
diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
|
|
index 1bca2d0a66f..19355f16601 100644
|
|
--- a/Source/WebCore/dom/Document.cpp
|
|
+++ b/Source/WebCore/dom/Document.cpp
|
|
@@ -4407,12 +4407,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
|
|
unsigned i = 0;
|
|
|
|
UChar32 c;
|
|
- U16_NEXT(characters, i, length, c)
|
|
+ U16_NEXT(characters, i, length, c);
|
|
if (!isValidNameStart(c))
|
|
return false;
|
|
|
|
while (i < length) {
|
|
- U16_NEXT(characters, i, length, c)
|
|
+ U16_NEXT(characters, i, length, c);
|
|
if (!isValidNamePart(c))
|
|
return false;
|
|
}
|
|
@@ -4474,7 +4474,7 @@ bool Document::parseQualifiedName(const String& qualifiedName, String& prefix, S
|
|
|
|
for (unsigned i = 0; i < length;) {
|
|
UChar32 c;
|
|
- U16_NEXT(qualifiedName, i, length, c)
|
|
+ U16_NEXT(qualifiedName, i, length, c);
|
|
if (c == ':') {
|
|
if (sawColon) {
|
|
ec = NAMESPACE_ERR;
|