mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
51 lines
3.1 KiB
Diff
51 lines
3.1 KiB
Diff
diff -Naur qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
|
--- qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:07:38.680665385 -0800
|
|
+++ qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:12:17.564001354 -0800
|
|
@@ -26,6 +26,9 @@
|
|
#include "wtf/StdLibExtras.h"
|
|
#include "wtf/text/CharacterNames.h"
|
|
|
|
+#include <unicode/uchar.h>
|
|
+#include <unicode/uvernum.h>
|
|
+
|
|
namespace blink {
|
|
|
|
unsigned numGraphemeClusters(const String& string)
|
|
@@ -122,13 +125,18 @@
|
|
{ B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), 0, B(0, 0, 0, 0, 0, 0, 0, 0), 0, 0, 0, B(0, 0, 0, 0, 0, 0, 0, 0), 0, 0, 0, B(0, 0, 0, 0, 0, 0, 0, 0) }, // DEL
|
|
};
|
|
|
|
+#if U_ICU_VERSION_MAJOR_NUM >= 58
|
|
+#define BA_LB_COUNT (U_LB_COUNT - 3)
|
|
+#else
|
|
+#define BA_LB_COUNT U_LB_COUNT
|
|
+#endif
|
|
// Line breaking table for CSS word-break: break-all. This table differs from
|
|
// asciiLineBreakTable in:
|
|
// - Indices are Line Breaking Classes defined in UAX#14 Unicode Line Breaking
|
|
// Algorithm: http://unicode.org/reports/tr14/#DescriptionOfProperties
|
|
// - 1 indicates additional break opportunities. 0 indicates to fallback to
|
|
// normal line break, not "prohibit break."
|
|
-static const unsigned char breakAllLineBreakClassTable[][U_LB_COUNT / 8 + 1] = {
|
|
+static const unsigned char breakAllLineBreakClassTable[][BA_LB_COUNT / 8 + 1] = {
|
|
// XX AI AL B2 BA BB BK CB CL CM CR EX GL HY ID IN IS LF NS NU OP PO PR QU SA SG SP SY ZW NL WJ H2 H3 JL JT JV CP CJ HL RI
|
|
{ B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0) }, // XX
|
|
{ B(0, 1, 1, 0, 1, 0, 0, 0), B(0, 0, 0, 0, 0, 1, 0, 0), B(0, 0, 0, 1, 1, 0, 1, 0), B(1, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 1, 0) }, // AI
|
|
@@ -178,7 +186,7 @@
|
|
#undef AL
|
|
|
|
static_assert(WTF_ARRAY_LENGTH(asciiLineBreakTable) == asciiLineBreakTableLastChar - asciiLineBreakTableFirstChar + 1, "asciiLineBreakTable should be consistent");
|
|
-static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == U_LB_COUNT, "breakAllLineBreakClassTable should be consistent");
|
|
+static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == BA_LB_COUNT, "breakAllLineBreakClassTable should be consistent");
|
|
|
|
static inline bool shouldBreakAfter(UChar lastCh, UChar ch, UChar nextCh)
|
|
{
|
|
@@ -209,7 +217,7 @@
|
|
|
|
static inline bool shouldBreakAfterBreakAll(ULineBreak lastLineBreak, ULineBreak lineBreak)
|
|
{
|
|
- if (lineBreak >= 0 && lineBreak < U_LB_COUNT && lastLineBreak >= 0 && lastLineBreak < U_LB_COUNT) {
|
|
+ if (lineBreak >= 0 && lineBreak < BA_LB_COUNT && lastLineBreak >= 0 && lastLineBreak < BA_LB_COUNT) {
|
|
const unsigned char* tableRow = breakAllLineBreakClassTable[lastLineBreak];
|
|
return tableRow[lineBreak / 8] & (1 << (lineBreak % 8));
|
|
}
|