mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
d6aed67fdf
add aarch64 support for rpi4
29 lines
1 KiB
Diff
29 lines
1 KiB
Diff
From 988f69b247fa3a1b70876395342aeb8c7dc2e834 Mon Sep 17 00:00:00 2001
|
|
From: graysky <graysky@archlinux.us>
|
|
Date: Mon, 7 Dec 2020 13:03:40 -0500
|
|
Subject: [PATCH] Make /proc/cpuinfo consistent on arm64 and arm
|
|
|
|
Signed-off-by: graysky <graysky@archlinux.us>
|
|
---
|
|
arch/arm64/kernel/cpuinfo.c | 5 ++---
|
|
1 file changed, 2 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/arch/arm64/kernel/cpuinfo.c b/arch/arm64/kernel/cpuinfo.c
|
|
index 721350d21074..88e2b8fcd7e6 100644
|
|
--- a/arch/arm64/kernel/cpuinfo.c
|
|
+++ b/arch/arm64/kernel/cpuinfo.c
|
|
@@ -153,9 +153,8 @@ static int c_show(struct seq_file *m, void *v)
|
|
* "processor". Give glibc what it expects.
|
|
*/
|
|
seq_printf(m, "processor\t: %d\n", i);
|
|
- if (compat)
|
|
- seq_printf(m, "model name\t: ARMv8 Processor rev %d (%s)\n",
|
|
- MIDR_REVISION(midr), COMPAT_ELF_PLATFORM);
|
|
+ seq_printf(m, "model name\t: ARMv8 Processor rev %d (%s)\n",
|
|
+ MIDR_REVISION(midr), COMPAT_ELF_PLATFORM);
|
|
|
|
seq_printf(m, "BogoMIPS\t: %lu.%02lu\n",
|
|
loops_per_jiffy / (500000UL/HZ),
|
|
--
|
|
2.29.2
|
|
|