mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
19 lines
1,009 B
Diff
19 lines
1,009 B
Diff
diff --git a/src/gallium/drivers/swr/rasterizer/codegen/gen_llvm_ir_macros.py b/src/gallium/drivers/swr/rasterizer/codegen/gen_llvm_ir_macros.py
|
|
index 025d38a..ce892a9 100644
|
|
--- a/src/gallium/drivers/swr/rasterizer/codegen/gen_llvm_ir_macros.py
|
|
+++ b/src/gallium/drivers/swr/rasterizer/codegen/gen_llvm_ir_macros.py
|
|
@@ -140,6 +140,14 @@ def parse_ir_builder(input_file):
|
|
|
|
ignore = False
|
|
|
|
+ # The following functions need to be ignored in openswr.
|
|
+ # API change in llvm-5.0 breaks baked autogen files
|
|
+ if (
|
|
+ (func_name == 'CreateFence' or
|
|
+ func_name == 'CreateAtomicCmpXchg' or
|
|
+ func_name == 'CreateAtomicRMW')):
|
|
+ ignore = True
|
|
+
|
|
# The following functions need to be ignored.
|
|
if (func_name == 'CreateInsertNUWNSWBinOp' or
|
|
func_name == 'CreateMaskedIntrinsic' or
|