mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
31 lines
1 KiB
Diff
31 lines
1 KiB
Diff
From aba843317d8acc4634417becebaedcfe5805d49d Mon Sep 17 00:00:00 2001
|
|
From: Lennart Poettering <lennart@poettering.net>
|
|
Date: Mon, 5 Jan 2015 01:56:47 +0100
|
|
Subject: [PATCH] systemctl: properly iterate through service array when
|
|
dispatching to sysv
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1175734
|
|
---
|
|
src/systemctl/systemctl.c | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/systemctl/systemctl.c b/src/systemctl/systemctl.c
|
|
index 9c4b9ed..3d939f0 100644
|
|
--- a/src/systemctl/systemctl.c
|
|
+++ b/src/systemctl/systemctl.c
|
|
@@ -5188,8 +5188,10 @@ static int enable_sysv_units(const char *verb, char **args) {
|
|
return -EPROTO;
|
|
|
|
/* Remove this entry, so that we don't try enabling it as native unit */
|
|
- assert(f > 0 && streq(args[f-1], name));
|
|
- assert_se(strv_remove(args + f - 1, name));
|
|
+ assert(f > 0);
|
|
+ f--;
|
|
+ assert(args[f] == name);
|
|
+ strv_remove(args, name);
|
|
}
|
|
|
|
#endif
|
|
--
|
|
2.3.0
|
|
|