PKGBUILDs/community/vtk/vtk-libharu-2.4.0.patch
2022-09-01 13:32:30 +00:00

33 lines
1.3 KiB
Diff

diff --git a/IO/ExportPDF/vtkPDFContextDevice2D.cxx b/IO/ExportPDF/vtkPDFContextDevice2D.cxx
index 2df979c303..541a73e882 100644
--- a/IO/ExportPDF/vtkPDFContextDevice2D.cxx
+++ b/IO/ExportPDF/vtkPDFContextDevice2D.cxx
@@ -1617,21 +1617,21 @@ void vtkPDFContextDevice2D::ApplyLineWidth(float width)
void vtkPDFContextDevice2D::ApplyLineType(int type)
{
// These match the OpenGL2 implementation:
- static const HPDF_UINT16 noPen[] = { 0, 10 };
+ static const HPDF_REAL noPen[] = { 0.0f, 10.0f };
static const HPDF_UINT noPenLen = 2;
- static const HPDF_UINT16 dash[] = { 8 };
+ static const HPDF_REAL dash[] = { 8.0f };
static const HPDF_UINT dashLen = 1;
- static const HPDF_UINT16 dot[] = { 1, 7 };
- static const HPDF_UINT16 denseDot[] = { 1, 3 };
+ static const HPDF_REAL dot[] = { 1.0f, 7.0f };
+ static const HPDF_REAL denseDot[] = { 1.0f, 3.0f };
static const HPDF_UINT dotLen = 2;
- static const HPDF_UINT16 dashDot[] = { 4, 6, 2, 4 };
+ static const HPDF_REAL dashDot[] = { 4.0f, 6.0f, 2.0f, 4.0f };
static const HPDF_UINT dashDotLen = 4;
// This is dash-dot-dash, but eh. It matches the OpenGL2 0x1C47 pattern.
- static const HPDF_UINT16 dashDotDot[] = { 3, 3, 1, 3, 3, 3 };
+ static const HPDF_REAL dashDotDot[] = { 3.0f, 3.0f, 1.0f, 3.0f, 3.0f, 3.0f };
static const HPDF_UINT dashDotDotLen = 6;
switch (type)