PKGBUILDs/core/flex/flex-2.5.35-gcc44.patch
2009-10-09 21:17:35 -05:00

23 lines
829 B
Diff

diff -urNp flex-2.5.35.orig/flex.skl flex-2.5.35/flex.skl
--- flex-2.5.35.orig/flex.skl 2009-04-20 03:09:46.000000000 +0530
+++ flex-2.5.35/flex.skl 2009-04-20 07:46:58.000000000 +0530
@@ -217,6 +217,7 @@ m4preproc_include(`flexint.h')
/* begin standard C++ headers. */
#include <iostream>
#include <errno.h>
+#include <cstdio>
#include <cstdlib>
#include <cstring>
/* end standard C++ headers. */
diff -urNp flex-2.5.35.orig/skel.c flex-2.5.35/skel.c
--- flex-2.5.35.orig/skel.c 2009-04-20 03:09:46.000000000 +0530
+++ flex-2.5.35/skel.c 2009-04-20 07:46:40.000000000 +0530
@@ -284,6 +284,7 @@ const char *skel[] = {
"/* begin standard C++ headers. */",
"#include <iostream> ",
"#include <errno.h>",
+ "#include <cstdio>",
"#include <cstdlib>",
"#include <cstring>",
"/* end standard C++ headers. */",