mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
18 lines
536 B
Diff
18 lines
536 B
Diff
look in /usr/share/games/simutrans for game data
|
|
|
|
@DPATCH@
|
|
|
|
--- simutrans.orig/simmain.cc
|
|
+++ simutrans/simmain.cc
|
|
@@ -437,8 +437,9 @@
|
|
strcat( env_t::program_dir, path_sep );
|
|
}
|
|
else {
|
|
- strcpy( env_t::program_dir, argv[0] );
|
|
- *(strrchr( env_t::program_dir, path_sep[0] )+1) = 0;
|
|
+ // strcpy( env_t::program_dir, argv[0] );
|
|
+ // *(strrchr( env_t::program_dir, path_sep[0] )+1) = 0;
|
|
+ strcpy(env_t::program_dir, "/usr/share/games/simutrans/");
|
|
|
|
#ifdef __APPLE__
|
|
// change working directory from binary dir to bundle dir
|