mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
2 KiB
Diff
54 lines
2 KiB
Diff
From 17e98757e78969a199d1d6318f53d088da192191 Mon Sep 17 00:00:00 2001
|
|
From: Even Rouault <even.rouault@spatialys.com>
|
|
Date: Fri, 18 Feb 2022 22:47:01 +0100
|
|
Subject: [PATCH] PDF: fix build against Poppler > 22.2
|
|
|
|
---
|
|
frmts/pdf/pdfdataset.cpp | 17 +++++++++++------
|
|
1 file changed, 11 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/frmts/pdf/pdfdataset.cpp b/frmts/pdf/pdfdataset.cpp
|
|
index 22238bd74822..08f8e31c86a7 100644
|
|
--- a/frmts/pdf/pdfdataset.cpp
|
|
+++ b/frmts/pdf/pdfdataset.cpp
|
|
@@ -4241,8 +4241,6 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
|
|
#ifdef HAVE_POPPLER
|
|
if(bUseLib.test(PDFLIB_POPPLER))
|
|
{
|
|
- GooString* poUserPwd = nullptr;
|
|
-
|
|
static bool globalParamsCreatedByGDAL = false;
|
|
{
|
|
CPLMutexHolderD(&hGlobalParamsMutex);
|
|
@@ -4310,9 +4308,6 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
|
|
while( true )
|
|
{
|
|
VSIFSeekL(fp, 0, SEEK_SET);
|
|
- if (pszUserPwd)
|
|
- poUserPwd = new GooString(pszUserPwd);
|
|
-
|
|
g_nPopplerErrors = 0;
|
|
if( globalParamsCreatedByGDAL )
|
|
registerErrorCallback();
|
|
@@ -4322,10 +4317,20 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
|
|
oObj.getObj()->initNull();
|
|
auto poStream = new VSIPDFFileStream(fp, pszFilename, oObj.getObj());
|
|
#endif
|
|
+#if POPPLER_MAJOR_VERSION > 22 || (POPPLER_MAJOR_VERSION == 22 && POPPLER_MINOR_VERSION > 2)
|
|
+ std::optional<GooString> osUserPwd;
|
|
+ if (pszUserPwd)
|
|
+ osUserPwd = std::optional<GooString>(pszUserPwd);
|
|
+ poDocPoppler = new PDFDoc(poStream, std::optional<GooString>(), osUserPwd);
|
|
+#else
|
|
+ GooString* poUserPwd = nullptr;
|
|
+ if (pszUserPwd)
|
|
+ poUserPwd = new GooString(pszUserPwd);
|
|
poDocPoppler = new PDFDoc(poStream, nullptr, poUserPwd);
|
|
+ delete poUserPwd;
|
|
+#endif
|
|
if( globalParamsCreatedByGDAL )
|
|
registerErrorCallback();
|
|
- delete poUserPwd;
|
|
if( g_nPopplerErrors >= MAX_POPPLER_ERRORS )
|
|
{
|
|
PDFFreeDoc(poDocPoppler);
|