PKGBUILDs/extra/texlive-bin/texlive-poppler-0.59.patch
2018-03-04 07:15:39 +00:00

633 lines
22 KiB
Diff

diff -ur source.orig/texk/web2c/luatexdir/image/pdftoepdf.w source/texk/web2c/luatexdir/image/pdftoepdf.w
--- source.orig/texk/web2c/luatexdir/image/pdftoepdf.w 2017-05-08 22:39:36.639375783 +0200
+++ source/texk/web2c/luatexdir/image/pdftoepdf.w 2017-09-19 11:23:36.586768739 +0200
@@ -224,7 +224,7 @@
free(checksum);
}
if (pdf_doc->doc == NULL) {
- docmemstream = new MemStream( docstream,0,streamsize, obj.initNull() );
+ docmemstream = new MemStream( docstream,0,streamsize, Object(objNull) );
doc = new PDFDoc(docmemstream); /* takes ownership of docmemstream */
pdf_doc->pc++;
if (!doc->isOk() || !doc->okToPrint()) {
@@ -408,9 +408,8 @@
Object obj1;
pdf_begin_array(pdf);
for (i = 0, l = array->getLength(); i < l; ++i) {
- array->getNF(i, &obj1);
+ obj1 = array->getNF(i);
copyObject(pdf, pdf_doc, &obj1);
- obj1.free();
}
pdf_end_array(pdf);
}
@@ -422,9 +421,8 @@
pdf_begin_dict(pdf);
for (i = 0, l = dict->getLength(); i < l; ++i) {
copyName(pdf, dict->getKey(i));
- dict->getValNF(i, &obj1);
+ obj1 = dict->getValNF(i);
copyObject(pdf, pdf_doc, &obj1);
- obj1.free();
}
pdf_end_dict(pdf);
}
@@ -510,13 +508,12 @@
PDFDoc *doc = pdf_doc->doc;
xref = doc->getXRef();
for (r = pdf_doc->inObjList; r != NULL;) {
- xref->fetch(r->ref.num, r->ref.gen, &obj1);
+ obj1 = xref->fetch(r->ref.num, r->ref.gen);
if (obj1.isStream())
pdf_begin_obj(pdf, r->num, OBJSTM_NEVER);
else
pdf_begin_obj(pdf, r->num, 2);
copyObject(pdf, pdf_doc, &obj1);
- obj1.free();
pdf_end_obj(pdf);
n = r->next;
delete r;
@@ -740,7 +737,7 @@
catalog = doc->getCatalog();
page = catalog->getPage(img_pagenum(idict));
pageref = catalog->getPageRef(img_pagenum(idict));
- doc->getXRef()->fetch(pageref->num, pageref->gen, &pageobj);
+ pageobj = doc->getXRef()->fetch(pageref->num, pageref->gen);
pageDict = pageobj.getDict();
/* write the Page header */
pdf_begin_obj(pdf, img_objnum(idict), OBJSTM_NEVER);
@@ -757,12 +754,11 @@
pdf_dict_add_int(pdf, "PTEX.PageNumber", (int) img_pagenum(idict));
}
if ((suppress_optional_info & 8) == 0) {
- doc->getDocInfoNF(&obj1);
+ obj1 = doc->getDocInfoNF();
if (obj1.isRef()) {
/* the info dict must be indirect (PDF Ref p. 61) */
pdf_dict_add_ref(pdf, "PTEX.InfoDict", addInObj(pdf, pdf_doc, obj1.getRef()));
}
- obj1.free();
}
if (img_is_bbox(idict)) {
bbox[0] = sp2bp(img_bbox(idict)[0]);
@@ -788,19 +784,17 @@
Now all relevant parts of the Page dictionary are copied. Metadata validity
check is needed(as a stream it must be indirect).
*/
- pageDict->lookupNF("Metadata", &obj1);
+ obj1 = pageDict->lookupNF("Metadata");
if (!obj1.isNull() && !obj1.isRef())
formatted_warning("pdf inclusion","/Metadata must be indirect object");
- obj1.free();
/* copy selected items in Page dictionary */
for (i = 0; pagedictkeys[i] != NULL; i++) {
- pageDict->lookupNF(pagedictkeys[i], &obj1);
+ obj1 = pageDict->lookupNF(pagedictkeys[i]);
if (!obj1.isNull()) {
pdf_add_name(pdf, pagedictkeys[i]);
/* preserves indirection */
copyObject(pdf, pdf_doc, &obj1);
}
- obj1.free();
}
/*
If there are no Resources in the Page dict of the embedded page,
@@ -808,32 +802,28 @@
PDF file, climbing up the tree until the Resources are found.
(This fixes a problem with Scribus 1.3.3.14.)
*/
- pageDict->lookupNF("Resources", &obj1);
+ obj1 = pageDict->lookupNF("Resources");
if (obj1.isNull()) {
op1 = &pagesobj1;
op2 = &pagesobj2;
- pageDict->lookup("Parent", op1);
+ *op1 = pageDict->lookup("Parent");
while (op1->isDict()) {
- obj1.free();
- op1->dictLookupNF("Resources", &obj1);
+ obj1 = op1->dictLookupNF("Resources");
if (!obj1.isNull()) {
pdf_add_name(pdf, "Resources");
copyObject(pdf, pdf_doc, &obj1);
break;
}
- op1->dictLookup("Parent", op2);
+ *op2 = op1->dictLookup("Parent");
optmp = op1;
op1 = op2;
op2 = optmp;
- op2->free();
};
if (!op1->isDict())
formatted_warning("pdf inclusion","Page /Resources missing");
- op1->free();
}
- obj1.free();
/* Write the Page contents. */
- page->getContents(&contents);
+ contents = page->getContents();
if (contents.isStream()) {
/*
Variant A: get stream and recompress under control of \pdfcompresslevel
@@ -844,27 +834,23 @@
Variant B: copy stream without recompressing
*/
- contents.streamGetDict()->lookup("F", &obj1);
+ obj1 = contents.streamGetDict()->lookup("F");
if (!obj1.isNull()) {
normal_error("pdf inclusion","unsupported external stream");
}
- obj1.free();
- contents.streamGetDict()->lookup("Length", &obj1);
+ obj1 = contents.streamGetDict()->lookup("Length");
pdf_add_name(pdf, "Length");
copyObject(pdf, pdf_doc, &obj1);
- obj1.free();
- contents.streamGetDict()->lookup("Filter", &obj1);
+ obj1 = contents.streamGetDict()->lookup("Filter");
if (!obj1.isNull()) {
pdf_add_name(pdf, "Filter");
copyObject(pdf, pdf_doc, &obj1);
- obj1.free();
- contents.streamGetDict()->lookup("DecodeParms", &obj1);
+ obj1 = contents.streamGetDict()->lookup("DecodeParms");
if (!obj1.isNull()) {
pdf_add_name(pdf, "DecodeParms");
copyObject(pdf, pdf_doc, &obj1);
}
}
- obj1.free();
pdf_end_dict(pdf);
pdf_begin_stream(pdf);
copyStreamStream(pdf, contents.getStream()->getUndecodedStream());
@@ -875,8 +861,8 @@
pdf_end_dict(pdf);
pdf_begin_stream(pdf);
for (i = 0, l = contents.arrayGetLength(); i < l; ++i) {
- copyStreamStream(pdf, (contents.arrayGet(i, &obj1))->getStream());
- obj1.free();
+ obj1 = contents.arrayGet(i);
+ copyStreamStream(pdf, obj1.getStream());
if (i < (l - 1)) {
/*
Put a space between streams to be on the safe side (streams
@@ -897,8 +883,6 @@
}
/* write out all indirect objects */
writeRefs(pdf, pdf_doc);
- contents.free();
- pageobj.free();
/*
unrefPdfDocument() must come after contents.free() and pageobj.free()!
TH: The next line makes repeated pdf inclusion unacceptably slow
diff -ur source.orig/texk/web2c/luatexdir/lua/lepdflib.cc source/texk/web2c/luatexdir/lua/lepdflib.cc
--- source.orig/texk/web2c/luatexdir/lua/lepdflib.cc 2017-05-08 22:39:36.689375107 +0200
+++ source/texk/web2c/luatexdir/lua/lepdflib.cc 2017-09-19 09:48:19.658021769 +0200
@@ -538,7 +538,7 @@
pdfdoc_changed_error(L); \
uout = new_Object_userdata(L); \
uout->d = new Object(); \
- ((in *) uin->d)->function((Object *) uout->d); \
+ *((Object *)uout->d) = ((in *) uin->d)->function(); \
uout->atype = ALLOC_LEPDF; \
uout->pc = uin->pc; \
uout->pd = uin->pd; \
@@ -668,13 +668,11 @@
static int m_Array_incRef(lua_State * L)
{
- int i;
udstruct *uin;
uin = (udstruct *) luaL_checkudata(L, 1, M_Array);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- i = ((Array *) uin->d)->incRef();
- lua_pushinteger(L, i);
+ lua_pushinteger(L, 1);
return 1;
}
@@ -685,8 +683,7 @@
uin = (udstruct *) luaL_checkudata(L, 1, M_Array);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- i = ((Array *) uin->d)->decRef();
- lua_pushinteger(L, i);
+ lua_pushinteger(L, 1);
return 1;
}
@@ -702,7 +699,7 @@
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|| (uobj->pd != NULL && uobj->pd->pc != uobj->pc))
pdfdoc_changed_error(L);
- ((Array *) uin->d)->add(((Object *) uobj->d));
+ ((Array *) uin->d)->add(std::move(*((Object *) uobj->d)));
return 0;
}
@@ -718,7 +715,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Array *) uin->d)->get(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Array *) uin->d)->get(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -739,7 +736,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Array *) uin->d)->getNF(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Array *) uin->d)->getNF(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -953,25 +950,21 @@
static int m_Dict_incRef(lua_State * L)
{
- int i;
udstruct *uin;
uin = (udstruct *) luaL_checkudata(L, 1, M_Dict);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- i = ((Dict *) uin->d)->incRef();
- lua_pushinteger(L, i);
+ lua_pushinteger(L, 1);
return 1;
}
static int m_Dict_decRef(lua_State * L)
{
- int i;
udstruct *uin;
uin = (udstruct *) luaL_checkudata(L, 1, M_Dict);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- i = ((Dict *) uin->d)->decRef();
- lua_pushinteger(L, i);
+ lua_pushinteger(L, 1);
return 1;
}
@@ -986,7 +979,7 @@
pdfdoc_changed_error(L);
s = copyString(luaL_checkstring(L, 2));
uobj = (udstruct *) luaL_checkudata(L, 3, M_Object);
- ((Dict *) uin->d)->add(s, ((Object *) uobj->d));
+ ((Dict *) uin->d)->add(s, std::move(*((Object *) uobj->d)));
return 0;
}
@@ -999,7 +992,7 @@
pdfdoc_changed_error(L);
s = luaL_checkstring(L, 2);
uobj = (udstruct *) luaL_checkudata(L, 3, M_Object);
- ((Dict *) uin->d)->set(s, ((Object *) uobj->d));
+ ((Dict *) uin->d)->set(s, std::move(*((Object *) uobj->d)));
return 0;
}
@@ -1027,7 +1020,7 @@
s = luaL_checkstring(L, 2);
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Dict *) uin->d)->lookup(s, (Object *) uout->d);
+ *((Object *) uout->d) = ((Dict *) uin->d)->lookup(s);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1044,7 +1037,7 @@
s = luaL_checkstring(L, 2);
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Dict *) uin->d)->lookupNF(s, (Object *) uout->d);
+ *((Object *) uout->d) = ((Dict *) uin->d)->lookupNF(s);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1096,7 +1089,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Dict *) uin->d)->getVal(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Dict *) uin->d)->getVal(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1117,7 +1110,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Dict *) uin->d)->getValNF(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Dict *) uin->d)->getValNF(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1381,9 +1374,9 @@
pdfdoc_changed_error(L);
luaL_checktype(L, 2, LUA_TBOOLEAN);
if (lua_toboolean(L, 2) != 0)
- ((Object *) uin->d)->initBool(gTrue);
+ *((Object *) uin->d) = Object(gTrue);
else
- ((Object *) uin->d)->initBool(gFalse);
+ *((Object *) uin->d) = Object(gFalse);
return 0;
}
@@ -1395,7 +1388,7 @@
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
i = luaL_checkint(L, 2);
- ((Object *) uin->d)->initInt(i);
+ *((Object *) uin->d) = Object(i);
return 0;
}
@@ -1407,7 +1400,7 @@
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
d = luaL_checknumber(L, 2);
- ((Object *) uin->d)->initReal(d);
+ *((Object *) uin->d) = Object(d);
return 0;
}
@@ -1422,7 +1415,7 @@
pdfdoc_changed_error(L);
s = luaL_checklstring(L, 2, &len);
gs = new GooString(s, len);
- ((Object *) uin->d)->initString(gs);
+ *((Object *) uin->d) = Object(gs);
return 0;
}
@@ -1434,7 +1427,7 @@
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
s = luaL_checkstring(L, 2);
- ((Object *) uin->d)->initName(s);
+ *((Object *) uin->d) = Object(objName, s);
return 0;
}
@@ -1444,13 +1437,14 @@
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initNull();
+ *((Object *) uin->d) = Object(objNull);
return 0;
}
static int m_Object_initArray(lua_State * L)
{
udstruct *uin, *uxref;
+ Array *a;
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
uxref = (udstruct *) luaL_checkudata(L, 2, M_XRef);
if (uin->pd != NULL && uxref->pd != NULL && uin->pd != uxref->pd)
@@ -1458,7 +1452,8 @@
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|| (uxref->pd != NULL && uxref->pd->pc != uxref->pc))
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initArray((XRef *) uxref->d);
+ a = new Array((XRef *) uxref->d);
+ *((Object *) uin->d) = Object(a);
return 0;
}
@@ -1469,6 +1464,7 @@
static int m_Object_initDict(lua_State * L)
{
udstruct *uin, *uxref;
+ Dict *d;
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
uxref = (udstruct *) luaL_checkudata(L, 2, M_XRef);
if (uin->pd != NULL && uxref->pd != NULL && uin->pd != uxref->pd)
@@ -1476,7 +1472,8 @@
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|| (uxref->pd != NULL && uxref->pd->pc != uxref->pc))
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initDict((XRef *) uxref->d);
+ d = new Dict((XRef *) uxref->d);
+ *((Object *) uin->d) = Object(d);
return 0;
}
@@ -1490,7 +1487,7 @@
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|| (ustream->pd != NULL && ustream->pd->pc != ustream->pc))
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initStream((Stream *) ustream->d);
+ *((Object *) uin->d) = Object((Stream *) ustream->d);
return 0;
}
@@ -1503,7 +1500,7 @@
pdfdoc_changed_error(L);
num = luaL_checkint(L, 2);
gen = luaL_checkint(L, 3);
- ((Object *) uin->d)->initRef(num, gen);
+ *((Object *) uin->d) = Object(num, gen);
return 0;
}
@@ -1515,7 +1512,7 @@
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
s = luaL_checkstring(L, 2);
- ((Object *) uin->d)->initCmd(CHARP_CAST s);
+ *((Object *) uin->d) = Object(objCmd, CHARP_CAST s);
return 0;
}
@@ -1525,7 +1522,7 @@
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initError();
+ *((Object *) uin->d) = Object(objError);
return 0;
}
@@ -1535,7 +1532,7 @@
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
- ((Object *) uin->d)->initEOF();
+ *((Object *) uin->d) = Object(objEOF);
return 0;
}
@@ -1551,7 +1548,7 @@
pdfdoc_changed_error(L);
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->fetch((XRef *) uxref->d, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->fetch((XRef *) uxref->d);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1816,7 +1813,7 @@
pdfdoc_changed_error(L);
if (!((Object *) uin->d)->isArray())
luaL_error(L, "Object is not an Array");
- ((Object *) uin->d)->arrayAdd((Object *) uobj->d);
+ ((Object *) uin->d)->arrayAdd(std::move(*((Object *) uobj->d)));
return 0;
}
@@ -1833,7 +1830,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->arrayGet(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->arrayGet(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1857,7 +1854,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->arrayGetNF(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->arrayGetNF(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1897,7 +1894,7 @@
pdfdoc_changed_error(L);
if (!((Object *) uin->d)->isDict())
luaL_error(L, "Object is not a Dict");
- ((Object *) uin->d)->dictAdd(copyString(s), (Object *) uobj->d);
+ ((Object *) uin->d)->dictAdd(copyString(s), std::move(*((Object *) uobj->d)));
return 0;
}
@@ -1915,7 +1912,7 @@
pdfdoc_changed_error(L);
if (!((Object *) uin->d)->isDict())
luaL_error(L, "Object is not a Dict");
- ((Object *) uin->d)->dictSet(s, (Object *) uobj->d);
+ ((Object *) uin->d)->dictSet(s, std::move(*((Object *) uobj->d)));
return 0;
}
@@ -1930,7 +1927,7 @@
if (((Object *) uin->d)->isDict()) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->dictLookup(s, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->dictLookup(s);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1950,7 +1947,7 @@
if (((Object *) uin->d)->isDict()) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->dictLookupNF(s, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->dictLookupNF(s);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -1991,7 +1988,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->dictGetVal(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->dictGetVal(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -2015,7 +2012,7 @@
if (i > 0 && i <= len) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((Object *) uin->d)->dictGetValNF(i - 1, (Object *) uout->d);
+ *((Object *) uout->d) = ((Object *) uin->d)->dictGetValNF(i - 1);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -2243,7 +2240,7 @@
m_poppler_get_poppler(Page, Dict, getPieceInfo);
m_poppler_get_poppler(Page, Dict, getSeparationInfo);
m_poppler_get_poppler(Page, Dict, getResourceDict);
-m_poppler_get_OBJECT(Page, getAnnots);
+m_poppler_get_OBJECT(Page, getAnnotsObject);
m_poppler_get_OBJECT(Page, getContents);
@@ -2270,7 +2267,7 @@
{"getPieceInfo", m_Page_getPieceInfo},
{"getSeparationInfo", m_Page_getSeparationInfo},
{"getResourceDict", m_Page_getResourceDict},
- {"getAnnots", m_Page_getAnnots},
+ {"getAnnots", m_Page_getAnnotsObject},
{"getContents", m_Page_getContents},
{"__tostring", m_Page__tostring},
{NULL, NULL} // sentinel
@@ -2520,7 +2517,7 @@
if (((PdfDocument *) uin->d)->doc->getXRef()->isOk()) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((PdfDocument *) uin->d)->doc->getDocInfo((Object *) uout->d);
+ *((Object *) uout->d) = ((PdfDocument *) uin->d)->doc->getDocInfo();
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -2538,7 +2535,7 @@
if (((PdfDocument *) uin->d)->doc->getXRef()->isOk()) {
uout = new_Object_userdata(L);
uout->d = new Object();
- ((PdfDocument *) uin->d)->doc->getDocInfoNF((Object *) uout->d);
+ *((Object *) uout->d) = ((PdfDocument *) uin->d)->doc->getDocInfoNF();
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -2841,7 +2838,7 @@
uout = new_Object_userdata(L);
uout->d = new Object();
origin = (Object *) (((Attribute *) uin->d)->getValue());
- origin->copy ( ((Object *)uout->d) );
+ *((Object *) uout->d) = origin->copy();
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -3320,7 +3317,7 @@
parent = root->findParentElement(i-1);
if (parent != NULL) {
uout = new_StructElement_userdata(L);
- uout->d = new StructElement( *parent );
+ uout->d = (StructElement *) parent;
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
@@ -3370,7 +3367,7 @@
gen = luaL_checkint(L, 3);
uout = new_Object_userdata(L);
uout->d = new Object();
- ((XRef *) uin->d)->fetch(num, gen, (Object *) uout->d);
+ *((Object *) uout->d) = ((XRef *) uin->d)->fetch(num, gen);
uout->atype = ALLOC_LEPDF;
uout->pc = uin->pc;
uout->pd = uin->pd;
diff -ur source.orig/texk/web2c/luatexdir/lua/lpdfscannerlib.cc source/texk/web2c/luatexdir/lua/lpdfscannerlib.cc
--- source.orig/texk/web2c/luatexdir/lua/lpdfscannerlib.cc 2017-05-08 22:39:36.692708395 +0200
+++ source/texk/web2c/luatexdir/lua/lpdfscannerlib.cc 2017-09-19 09:48:19.658021769 +0200
@@ -634,7 +634,7 @@
int i;
for (i=0;i<count;i++) {
Object *val = new Object();
- arrayref->get(i, val);
+ *val = arrayref->get(i);
if (val->isStream()) {
ObjectList *rover = self->_streams;
ObjectList *item = (ObjectList *)priv_xmalloc (sizeof(ObjectList));