PKGBUILDs/extra/chmlib/arm.patch
2015-07-18 20:21:30 +00:00

22 lines
757 B
Diff

diff -urN a/src/chm_lib.c b/src/chm_lib.c
--- a/src/chm_lib.c 2009-05-23 08:43:31.000000000 -0600
+++ b/src/chm_lib.c 2015-07-18 14:15:00.588557608 -0600
@@ -153,7 +153,7 @@
/* Sparc */
/* MIPS */
/* PPC */
-#elif __i386__ || __sun || __sgi || __ppc__
+#elif __i386__ || __sun || __sgi || __ppc__ || __arm__
typedef unsigned char UChar;
typedef short Int16;
typedef unsigned short UInt16;
@@ -164,7 +164,7 @@
/* x86-64 */
/* Note that these may be appropriate for other 64-bit machines. */
-#elif __x86_64__ || __ia64__
+#elif __x86_64__ || __ia64__ || __aarch64__
typedef unsigned char UChar;
typedef short Int16;
typedef unsigned short UInt16;