PKGBUILDs/core/pacman/pacman-5.2.1-fix-pactest-package-tar-format.patch
2020-05-03 03:13:55 +00:00

33 lines
1.2 KiB
Diff

From b9faf652735c603d1bdf849a570185eb721f11c1 Mon Sep 17 00:00:00 2001
From: Allan McRae <allan@archlinux.org>
Date: Tue, 12 Nov 2019 16:14:57 +1000
Subject: pactest: set package tar format to GNU_FORMAT
python-3.8 changed the default tar format to PAX_FORMAT. This caused
issues in our testsuite with package extraction of files with UTF-8
characters as we run the tests under the C locale.
sycn600.py:
error: error while reading package /tmp/pactest-xuhri4xa/var/cache/pacman/pkg/unicodechars-2.0-1.pkg.tar.gz: Pathname can't be converted from UTF-8 to current locale.
Set format back to GNU_FORMAT.
Signed-off-by: Allan McRae <allan@archlinux.org>
---
test/pacman/pmpkg.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/pacman/pmpkg.py b/test/pacman/pmpkg.py
index 6a845222..e40868cc 100644
--- a/test/pacman/pmpkg.py
+++ b/test/pacman/pmpkg.py
@@ -142,7 +142,7 @@ class pmpkg(object):
util.mkdir(os.path.dirname(self.path))
# Generate package metadata
- tar = tarfile.open(self.path, "w:gz")
+ tar = tarfile.open(self.path, "w:gz", format=tarfile.GNU_FORMAT)
for name, data in archive_files:
info = tarfile.TarInfo(name)
info.size = len(data)