mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
0166f09d66
* rebuild on 5.9.1 * add patch for segfaults with gcc7
34 lines
1.6 KiB
Diff
34 lines
1.6 KiB
Diff
diff -u -r webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h
|
|
--- webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h 2017-02-20 17:20:15.000000000 +0100
|
|
+++ webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h 2017-06-27 13:13:57.801527350 +0200
|
|
@@ -581,29 +581,7 @@
|
|
// FIXME: Does this really belong in StringImpl?
|
|
template <typename T> static void copyChars(T* destination, const T* source, unsigned numCharacters)
|
|
{
|
|
- if (numCharacters == 1) {
|
|
- *destination = *source;
|
|
- return;
|
|
- }
|
|
-
|
|
- if (numCharacters <= s_copyCharsInlineCutOff) {
|
|
- unsigned i = 0;
|
|
-#if (CPU(X86) || CPU(X86_64))
|
|
- const unsigned charsPerInt = sizeof(uint32_t) / sizeof(T);
|
|
-
|
|
- if (numCharacters > charsPerInt) {
|
|
- unsigned stopCount = numCharacters & ~(charsPerInt - 1);
|
|
-
|
|
- const uint32_t* srcCharacters = reinterpret_cast<const uint32_t*>(source);
|
|
- uint32_t* destCharacters = reinterpret_cast<uint32_t*>(destination);
|
|
- for (unsigned j = 0; i < stopCount; i += charsPerInt, ++j)
|
|
- destCharacters[j] = srcCharacters[j];
|
|
- }
|
|
-#endif
|
|
- for (; i < numCharacters; ++i)
|
|
- destination[i] = source[i];
|
|
- } else
|
|
- memcpy(destination, source, numCharacters * sizeof(T));
|
|
+ memcpy(destination, source, numCharacters * sizeof(T));
|
|
}
|
|
|
|
ALWAYS_INLINE static void copyChars(UChar* destination, const LChar* source, unsigned numCharacters)
|