mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
84 lines
2.1 KiB
Diff
84 lines
2.1 KiB
Diff
From deda59a4022fcedd781a893fe5e1bb495988858f Mon Sep 17 00:00:00 2001
|
|
From: Jeroen Hofstee <jeroen@myspectrum.nl>
|
|
Date: Wed, 8 Oct 2014 22:57:22 +0200
|
|
Subject: [PATCH 5/6] common: board: use __weak
|
|
|
|
Signed-off-by: Jeroen Hofstee <jeroen@myspectrum.nl>
|
|
---
|
|
common/board_f.c | 10 ++--------
|
|
common/board_r.c | 10 ++--------
|
|
2 files changed, 4 insertions(+), 16 deletions(-)
|
|
|
|
diff --git a/common/board_f.c b/common/board_f.c
|
|
index 4ea4cb2..215cc4a 100644
|
|
--- a/common/board_f.c
|
|
+++ b/common/board_f.c
|
|
@@ -130,14 +130,11 @@ int init_func_watchdog_reset(void)
|
|
}
|
|
#endif /* CONFIG_WATCHDOG */
|
|
|
|
-void __board_add_ram_info(int use_default)
|
|
+__weak void board_add_ram_info(int use_default)
|
|
{
|
|
/* please define platform specific board_add_ram_info() */
|
|
}
|
|
|
|
-void board_add_ram_info(int)
|
|
- __attribute__ ((weak, alias("__board_add_ram_info")));
|
|
-
|
|
static int init_baud_rate(void)
|
|
{
|
|
gd->baudrate = getenv_ulong("baudrate", 10, CONFIG_BAUDRATE);
|
|
@@ -219,7 +216,7 @@ static int show_dram_config(void)
|
|
return 0;
|
|
}
|
|
|
|
-void __dram_init_banksize(void)
|
|
+__weak void dram_init_banksize(void)
|
|
{
|
|
#if defined(CONFIG_NR_DRAM_BANKS) && defined(CONFIG_SYS_SDRAM_BASE)
|
|
gd->bd->bi_dram[0].start = CONFIG_SYS_SDRAM_BASE;
|
|
@@ -227,9 +224,6 @@ void __dram_init_banksize(void)
|
|
#endif
|
|
}
|
|
|
|
-void dram_init_banksize(void)
|
|
- __attribute__((weak, alias("__dram_init_banksize")));
|
|
-
|
|
#if defined(CONFIG_HARD_I2C) || defined(CONFIG_SYS_I2C)
|
|
static int init_func_i2c(void)
|
|
{
|
|
diff --git a/common/board_r.c b/common/board_r.c
|
|
index 602a239..fa4bd9c 100644
|
|
--- a/common/board_r.c
|
|
+++ b/common/board_r.c
|
|
@@ -60,7 +60,7 @@ DECLARE_GLOBAL_DATA_PTR;
|
|
|
|
ulong monitor_flash_len;
|
|
|
|
-int __board_flash_wp_on(void)
|
|
+__weak int board_flash_wp_on(void)
|
|
{
|
|
/*
|
|
* Most flashes can't be detected when write protection is enabled,
|
|
@@ -70,16 +70,10 @@ int __board_flash_wp_on(void)
|
|
return 0;
|
|
}
|
|
|
|
-int board_flash_wp_on(void)
|
|
- __attribute__ ((weak, alias("__board_flash_wp_on")));
|
|
-
|
|
-void __cpu_secondary_init_r(void)
|
|
+__weak void cpu_secondary_init_r(void)
|
|
{
|
|
}
|
|
|
|
-void cpu_secondary_init_r(void)
|
|
- __attribute__ ((weak, alias("__cpu_secondary_init_r")));
|
|
-
|
|
static int initr_secondary_cpu(void)
|
|
{
|
|
/*
|
|
--
|
|
2.4.4
|
|
|