mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
22 lines
845 B
Diff
22 lines
845 B
Diff
diff --git a/src/ImageConverter.cpp b/src/ImageConverter.cpp
|
|
index dc7605b..56f59db 100644
|
|
--- a/src/ImageConverter.cpp
|
|
+++ b/src/ImageConverter.cpp
|
|
@@ -70,7 +70,7 @@ void ImageConverter::convert(const cv::Mat * in, QImage * out)
|
|
|
|
cv::Mat tmp(in->cols, in->rows, in->depth());
|
|
|
|
- cvtColor(*in, tmp, (in->channels() == 1) ? CV_GRAY2RGB : CV_BGR2RGB);
|
|
+ cvtColor(*in, tmp, (in->channels() == 1) ? cv::COLOR_GRAY2RGB : cv::COLOR_BGR2RGB);
|
|
|
|
const unsigned int w3 = 3 * tmp.cols;
|
|
unsigned char * src = reinterpret_cast<unsigned char *>(tmp.ptr());
|
|
@@ -106,7 +106,7 @@ void ImageConverter::convert(const QImage & in, cv::Mat ** out)
|
|
dst += step;
|
|
}
|
|
}
|
|
- cvtColor(**out, **out, CV_BGR2RGB);
|
|
+ cvtColor(**out, **out, cv::COLOR_BGR2RGB);
|
|
}
|
|
|
|
void ImageConverter::convert(const cimg_library::CImg<float> & in, QImage * out)
|