mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
52 lines
2 KiB
Diff
52 lines
2 KiB
Diff
From 17f1cb1d99e66227d1e05925ef937643f5c1089a Mon Sep 17 00:00:00 2001
|
|
From: Jan de Groot <jan@jgc.homeip.net>
|
|
Date: Thu, 07 Mar 2013 18:48:13 +0000
|
|
Subject: dri/nouveau: fix crash in nouveau_flush
|
|
|
|
https://bugs.freedesktop.org/show_bug.cgi?id=61947
|
|
|
|
Note: this is a candidate for the stable branches
|
|
---
|
|
diff --git a/src/mesa/drivers/dri/nouveau/nouveau_driver.c b/src/mesa/drivers/dri/nouveau/nouveau_driver.c
|
|
index f56b3b2..6c119d5 100644
|
|
--- a/src/mesa/drivers/dri/nouveau/nouveau_driver.c
|
|
+++ b/src/mesa/drivers/dri/nouveau/nouveau_driver.c
|
|
@@ -69,7 +69,8 @@ nouveau_flush(struct gl_context *ctx)
|
|
__DRIdri2LoaderExtension *dri2 = screen->dri2.loader;
|
|
__DRIdrawable *drawable = nctx->dri_context->driDrawablePriv;
|
|
|
|
- dri2->flushFrontBuffer(drawable, drawable->loaderPrivate);
|
|
+ if (drawable && drawable->loaderPrivate)
|
|
+ dri2->flushFrontBuffer(drawable, drawable->loaderPrivate);
|
|
}
|
|
}
|
|
|
|
--
|
|
cgit v0.9.0.2-2-gbebe
|
|
From e062a4187d8ea518a39c913ae7562cf1d8ac3205 Mon Sep 17 00:00:00 2001
|
|
From: Tapani Pälli <tapani.palli@intel.com>
|
|
Date: Mon, 28 Jan 2013 06:53:56 +0000
|
|
Subject: intel: Fix regression in intel_create_image_from_name stride handling
|
|
|
|
Strangely, the DRIimage interface we have passes the pitch in pixels
|
|
instead of bytes, which anholt missed in the change to using bytes for
|
|
region pitch.
|
|
|
|
Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
diff --git a/src/mesa/drivers/dri/intel/intel_screen.c b/src/mesa/drivers/dri/intel/intel_screen.c
|
|
index defcd73..d223a0b 100644
|
|
--- a/src/mesa/drivers/dri/intel/intel_screen.c
|
|
+++ b/src/mesa/drivers/dri/intel/intel_screen.c
|
|
@@ -377,7 +377,7 @@ intel_create_image_from_name(__DRIscreen *screen,
|
|
cpp = _mesa_get_format_bytes(image->format);
|
|
image->region = intel_region_alloc_for_handle(intelScreen,
|
|
cpp, width, height,
|
|
- pitch, name, "image");
|
|
+ pitch * cpp, name, "image");
|
|
if (image->region == NULL) {
|
|
free(image);
|
|
return NULL;
|
|
--
|
|
cgit v0.9.0.2-2-gbebe
|