mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
32 lines
925 B
Diff
32 lines
925 B
Diff
dm9601: Added support for usb ethernet (0x0fe6, 0x9700)
|
|
|
|
The device is very similar to (0x0fe6, 0x8101),
|
|
And works well with dm9601 driver.
|
|
|
|
Upstream-Status: Backport [2.6.38]
|
|
|
|
Signed-off-by: Shahar Havivi <shaharh@redhat.com>
|
|
Acked-by: Peter Korsgaard <jacmet@sunsite.dk>
|
|
Signed-off-by: David S. Miller <davem@davemloft.net>
|
|
---
|
|
drivers/net/usb/dm9601.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/drivers/net/usb/dm9601.c b/drivers/net/usb/dm9601.c
|
|
index 02b622e..5002f5b 100644
|
|
--- a/drivers/net/usb/dm9601.c
|
|
+++ b/drivers/net/usb/dm9601.c
|
|
@@ -651,6 +651,10 @@ static const struct usb_device_id products[] = {
|
|
.driver_info = (unsigned long)&dm9601_info,
|
|
},
|
|
{
|
|
+ USB_DEVICE(0x0fe6, 0x9700), /* DM9601 USB to Fast Ethernet Adapter */
|
|
+ .driver_info = (unsigned long)&dm9601_info,
|
|
+ },
|
|
+ {
|
|
USB_DEVICE(0x0a46, 0x9000), /* DM9000E */
|
|
.driver_info = (unsigned long)&dm9601_info,
|
|
},
|
|
--
|
|
1.7.10
|
|
|