PKGBUILDs/extra/ceph/no-neon.patch
2015-09-18 03:27:39 +00:00

119 lines
2.8 KiB
Diff

diff -urN a/configure b/configure
--- a/configure 2015-08-26 11:51:18.000000000 -0600
+++ b/configure 2015-09-17 20:46:42.152578212 -0600
@@ -20782,112 +20782,8 @@
fi
-# Find supported SIMD / NEON / SSE extensions supported by the compiler
-
-
-
- case $target_cpu in
- arm*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -mfpu=neon" >&5
-$as_echo_n "checking whether C compiler accepts -mfpu=neon... " >&6; }
-if ${ax_cv_check_cflags___mfpu_neon+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -mfpu=neon"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___mfpu_neon=yes
-else
- ax_cv_check_cflags___mfpu_neon=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___mfpu_neon" >&5
-$as_echo "$ax_cv_check_cflags___mfpu_neon" >&6; }
-if test x"$ax_cv_check_cflags___mfpu_neon" = xyes; then :
- ax_cv_support_neon_ext=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
- ARM_NEON_FLAGS="-mfpu=neon -DARM_NEON"
-
- ARM_FLAGS="$ARM_FLAGS $ARM_NEON_FLAGS"
-
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
-
- fi
- ;;
- aarch64*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -march=armv8-a+simd" >&5
-$as_echo_n "checking whether C compiler accepts -march=armv8-a+simd... " >&6; }
-if ${ax_cv_check_cflags___march_armv8_apsimd+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -march=armv8-a+simd"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___march_armv8_apsimd=yes
-else
- ax_cv_check_cflags___march_armv8_apsimd=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___march_armv8_apsimd" >&5
-$as_echo "$ax_cv_check_cflags___march_armv8_apsimd" >&6; }
-if test x"$ax_cv_check_cflags___march_armv8_apsimd" = xyes; then :
- ax_cv_support_neon_ext=yes
-else
- :
-fi
-
- if test x"$ax_cv_support_neon_ext" = x"yes"; then
- ARM_NEON_FLAGS="-march=armv8-a+simd -DARCH_AARCH64 -DARM_NEON"
-
- ARM_FLAGS="$ARM_FLAGS $ARM_NEON_FLAGS"
-
-$as_echo "#define HAVE_NEON /**/" >>confdefs.h
-
- fi
- ;;
- esac
-
-
-
- if test "x$ax_cv_support_neon_ext" = "xyes"; then
- HAVE_NEON_TRUE=
- HAVE_NEON_FALSE='#'
-else
- HAVE_NEON_TRUE='#'
- HAVE_NEON_FALSE=
-fi
+HAVE_NEON_TRUE='#'
+HAVE_NEON_FALSE=