mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
21 lines
731 B
Diff
21 lines
731 B
Diff
--- a/build/config/compiler/BUILD.gn
|
|
+++ b/build/config/compiler/BUILD.gn
|
|
@@ -422,18 +422,6 @@
|
|
cflags += [ "-fcolor-diagnostics" ]
|
|
}
|
|
|
|
- # TODO(hans): Remove this once Clang generates better optimized debug info by
|
|
- # default. https://crbug.com/765793
|
|
- if (is_clang && !is_nacl && current_toolchain == host_toolchain &&
|
|
- target_os != "chromeos") {
|
|
- cflags += [
|
|
- "-Xclang",
|
|
- "-mllvm",
|
|
- "-Xclang",
|
|
- "-instcombine-lower-dbg-declare=0",
|
|
- ]
|
|
- }
|
|
-
|
|
# Print absolute paths in diagnostics. There is no precedent for doing this
|
|
# on Linux/Mac (GCC doesn't support it), but MSVC does this with /FC and
|
|
# Windows developers rely on it (crbug.com/636109) so only do this on Windows.
|