mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
eef7b99e58
Build VLC with HW decoding for RPi models bearing hardware support for it
14 lines
443 B
Diff
14 lines
443 B
Diff
--- a/bin/vlc.c
|
|
+++ b/bin/vlc.c
|
|
@@ -106,7 +106,10 @@ static void vlc_kill (void *data)
|
|
static void exit_timeout (int signum)
|
|
{
|
|
(void) signum;
|
|
- signal (SIGINT, SIG_DFL);
|
|
+// This doesn't seem to be strong enough to reliably kill us if we fail to exit
|
|
+// in a timely fashion - so upgrade to _exit().
|
|
+// signal (SIGINT, SIG_DFL);
|
|
+ _exit(0);
|
|
}
|
|
|
|
/*****************************************************************************
|