mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
28 lines
970 B
Diff
28 lines
970 B
Diff
From 5811dd08f263a88613807ac3261f31c0a11ae507 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sun, 23 Apr 2017 16:56:55 -0600
|
|
Subject: [PATCH 5/5] Don't pair touchpad and lid switch
|
|
|
|
Kills Xorg immediately upon any touchpad or keyboard entry on the Samsung Chromebook Plus.
|
|
|
|
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
---
|
|
src/evdev-mt-touchpad.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
|
|
index 184d37d..bb034c5 100644
|
|
--- a/src/evdev-mt-touchpad.c
|
|
+++ b/src/evdev-mt-touchpad.c
|
|
@@ -1635,7 +1635,7 @@ tp_interface_device_added(struct evdev_device *device,
|
|
|
|
tp_pair_trackpoint(device, added_device);
|
|
tp_dwt_pair_keyboard(device, added_device);
|
|
- tp_pair_lid_switch(device, added_device);
|
|
+ /*tp_pair_lid_switch(device, added_device);*/
|
|
|
|
if (tp->sendevents.current_mode !=
|
|
LIBINPUT_CONFIG_SEND_EVENTS_DISABLED_ON_EXTERNAL_MOUSE)
|
|
--
|
|
2.12.2
|
|
|