mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
64 lines
2.8 KiB
Diff
64 lines
2.8 KiB
Diff
From 5a2cd2409c7d65c019ad9f4595a4e85315857ac4 Mon Sep 17 00:00:00 2001
|
|
From: Tom Anderson <thomasanderson@chromium.org>
|
|
Date: Mon, 3 Feb 2020 23:18:46 +0000
|
|
Subject: [PATCH] Rename Relayout() in DesktopWindowTreeHostPlatform to
|
|
ScheduleRelayout()
|
|
|
|
R=sky
|
|
|
|
Bug: None
|
|
Change-Id: I680cafd25935e59a280e3b2baac754d3d5f13a35
|
|
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2036553
|
|
Auto-Submit: Thomas Anderson <thomasanderson@chromium.org>
|
|
Reviewed-by: Scott Violet <sky@chromium.org>
|
|
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
|
|
Cr-Commit-Position: refs/heads/master@{#737974}
|
|
---
|
|
.../desktop_aura/desktop_window_tree_host_platform.cc | 6 +++---
|
|
.../widget/desktop_aura/desktop_window_tree_host_platform.h | 2 +-
|
|
2 files changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
|
|
index 6c00d49eb3f..9c695d8e5b1 100644
|
|
--- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
|
|
+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.cc
|
|
@@ -556,7 +556,7 @@ void DesktopWindowTreeHostPlatform::SetFullscreen(bool fullscreen) {
|
|
DCHECK_EQ(fullscreen, IsFullscreen());
|
|
|
|
if (IsFullscreen() == fullscreen)
|
|
- Relayout();
|
|
+ ScheduleRelayout();
|
|
// Else: the widget will be relaid out either when the window bounds change
|
|
// or when |platform_window|'s fullscreen state changes.
|
|
}
|
|
@@ -669,7 +669,7 @@ void DesktopWindowTreeHostPlatform::OnWindowStateChanged(
|
|
// Now that we have different window properties, we may need to relayout the
|
|
// window. (The windows code doesn't need this because their window change is
|
|
// synchronous.)
|
|
- Relayout();
|
|
+ ScheduleRelayout();
|
|
}
|
|
|
|
void DesktopWindowTreeHostPlatform::OnCloseRequest() {
|
|
@@ -712,7 +712,7 @@ gfx::Rect DesktopWindowTreeHostPlatform::ToPixelRect(
|
|
return gfx::ToEnclosingRect(rect_in_pixels);
|
|
}
|
|
|
|
-void DesktopWindowTreeHostPlatform::Relayout() {
|
|
+void DesktopWindowTreeHostPlatform::ScheduleRelayout() {
|
|
Widget* widget = native_widget_delegate_->AsWidget();
|
|
NonClientView* non_client_view = widget->non_client_view();
|
|
// non_client_view may be NULL, especially during creation.
|
|
diff --git a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
|
|
index 89beb8d2245..75a401e02a7 100644
|
|
--- a/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
|
|
+++ b/ui/views/widget/desktop_aura/desktop_window_tree_host_platform.h
|
|
@@ -129,7 +129,7 @@ class VIEWS_EXPORT DesktopWindowTreeHostPlatform
|
|
gfx::Rect ToPixelRect(const gfx::Rect& rect_in_dip) const;
|
|
|
|
private:
|
|
- void Relayout();
|
|
+ void ScheduleRelayout();
|
|
|
|
Widget* GetWidget();
|
|
const Widget* GetWidget() const;
|