PKGBUILDs/extra/ffmpeg/ffmpeg-2.6.3-lavd-xcbgrab-fix-comparison-with-screen-size.patch
2015-05-30 12:40:07 +00:00

30 lines
1 KiB
Diff

From 7971fa9ce0ead8d2e8a79dbe422e91dcef8222ba Mon Sep 17 00:00:00 2001
From: Nicolas George <george@nsup.org>
Date: Wed, 6 May 2015 11:53:19 +0200
Subject: [PATCH] lavd/xcbgrab: fix comparison with screen size.
Signed-off-by: Nicolas George <george@nsup.org>
Signed-off-by: Michael Niedermayer <michaelni@gmx.at>
---
libavdevice/xcbgrab.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavdevice/xcbgrab.c b/libavdevice/xcbgrab.c
index 15512cd..166575c 100644
--- a/libavdevice/xcbgrab.c
+++ b/libavdevice/xcbgrab.c
@@ -533,8 +533,8 @@ static int create_stream(AVFormatContext *s)
gc = xcb_get_geometry(c->conn, c->screen->root);
geo = xcb_get_geometry_reply(c->conn, gc, NULL);
- if (c->x + c->width >= geo->width ||
- c->y + c->height >= geo->height) {
+ if (c->x + c->width > geo->width ||
+ c->y + c->height > geo->height) {
av_log(s, AV_LOG_ERROR,
"Capture area %dx%d at position %d.%d "
"outside the screen size %dx%d\n",
--
1.7.10.4