PKGBUILDs/extra/kdebindings-python/pyqt495.patch
2012-10-18 13:34:09 +00:00

82 lines
1.7 KiB
Diff

diff -urN a/sip/kdecore/typedefs.sip b/sip/kdecore/typedefs.sip
--- a/sip/kdecore/typedefs.sip 2012-09-27 18:18:24.000000000 -0600
+++ b/sip/kdecore/typedefs.sip 2012-10-18 07:32:15.490502568 -0600
@@ -951,77 +951,3 @@
%End
};
-%MappedType QVector<int>
-{
-%TypeHeaderCode
-#include <qvector.h>
-%End
-
-%ConvertFromTypeCode
- // Create the list.
- PyObject *l;
-
- if ((l = PyList_New(sipCpp->size())) == NULL)
- return NULL;
-
- // Set the list elements.
- for (int i = 0; i < sipCpp->size(); ++i)
- {
- int t = (sipCpp->at(i));
-
-#if PY_MAJOR_VERSION >= 3
- PyObject *tobj = PyLong_FromLong(t);
-#else
- PyObject *tobj = PyInt_FromLong(t);
-#endif
-
- PyList_SET_ITEM(l, i, tobj);
- }
-
- return l;
-%End
-
-%ConvertToTypeCode
- // Check the type if that is all that is required.
- if (sipIsErr == NULL)
- {
- if (!PyList_Check(sipPy))
- return 0;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i) {
- PyObject *tobj = PyList_GET_ITEM(sipPy, i);
-#if PY_MAJOR_VERSION >= 3
- if (!PyNumber_Check(tobj))
-#else
- if (!PyInt_Check(tobj))
-#endif
- return 0;
- }
- return 1;
- }
-
- QVector<int> *qv = new QVector<int>;
-
- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
- {
- PyObject *tobj = PyList_GET_ITEM(sipPy, i);
- #if PY_MAJOR_VERSION >= 3
- int t = PyLong_AsLong (tobj);
-#else
- int t = PyInt_AS_LONG (tobj);
-#endif
-
- if (*sipIsErr)
- {
- delete qv;
- return 0;
- }
-
- qv->append(t);
- }
-
- *sipCppPtr = qv;
-
- return sipGetState(sipTransferObj);
-%End
-};