mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
9 lines
291 B
Diff
9 lines
291 B
Diff
--- shadow-4.1.2.1/libmisc/xmalloc.c 2008-08-30 21:55:44.000000000 -0500
|
|
+++ shadow-4.1.2.1/libmisc/xmalloc.c.new 2008-08-30 21:55:36.000000000 -0500
|
|
@@ -61,5 +61,6 @@
|
|
|
|
char *xstrdup (const char *str)
|
|
{
|
|
+ if(str == NULL) return NULL;
|
|
return strcpy (xmalloc (strlen (str) + 1), str);
|
|
}
|