mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
diff -Naurp a2ps-4.13.orig/lib/fnmatch.c a2ps-4.13/lib/fnmatch.c
|
|
--- a2ps-4.13.orig/lib/fnmatch.c 2002-03-04 12:46:25 -0600
|
|
+++ a2ps-4.13/lib/fnmatch.c 2006-05-27 11:41:15 -0500
|
|
@@ -27,18 +27,6 @@
|
|
#include <fnmatch.h>
|
|
#include <ctype.h>
|
|
|
|
-
|
|
-/* Comment out all this code if we are using the GNU C Library, and are not
|
|
- actually compiling the library itself. This code is part of the GNU C
|
|
- Library, but also included in many other GNU distributions. Compiling
|
|
- and linking in this code is a waste when using the GNU C library
|
|
- (especially if it is a shared library). Rather than having every GNU
|
|
- program understand `configure --with-gnu-libc' and omit the object files,
|
|
- it is simpler to just do this in the source for each such file. */
|
|
-
|
|
-#if defined _LIBC || !defined __GNU_LIBRARY__
|
|
-
|
|
-
|
|
# if defined STDC_HEADERS || !defined isascii
|
|
# define ISASCII(c) 1
|
|
# else
|
|
@@ -52,10 +40,13 @@
|
|
extern int errno;
|
|
# endif
|
|
|
|
+/* fnmatch replacement taken from the GNU C Library for systems that
|
|
+ provide a broken implementation. */
|
|
+
|
|
/* Match STRING against the filename pattern PATTERN, returning zero if
|
|
it matches, nonzero if not. */
|
|
int
|
|
-fnmatch (const char *pattern, const char *string, int flags)
|
|
+rpl_fnmatch (const char *pattern, const char *string, int flags)
|
|
{
|
|
register const char *p = pattern, *n = string;
|
|
register char c;
|
|
@@ -233,5 +224,3 @@ fnmatch (const char *pattern, const char
|
|
|
|
# undef FOLD
|
|
}
|
|
-
|
|
-#endif /* _LIBC or not __GNU_LIBRARY__. */
|