PKGBUILDs/extra/rockdodger/rockdodger-0.6.0a-gcc41.patch
2009-10-09 21:23:22 -05:00

18 lines
516 B
Diff

--- main.c.old 2006-04-24 16:16:13.000000000 +0200
+++ main.c 2006-04-24 16:16:21.000000000 +0200
@@ -206,7 +206,6 @@
struct bangdots bdot[MAX_BANG_DOTS], *bdotptr=bdot;
struct spacedot sdot[MAX_SPACE_DOTS];
-struct greeble greeb[MAX_GREEBLES];
struct greeble {
int active;
float x,y; // When landed, these represent an offset from the host rock
@@ -214,6 +213,7 @@
int landed;
int boredom; // Goes up while landed
};
+struct greeble greeb[MAX_GREEBLES];
// }}}
void init_greeblies() {