mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
36 lines
1.6 KiB
Diff
36 lines
1.6 KiB
Diff
diff -Naur gcc-4.6-20120120-orig/configure gcc-4.6-20120120/configure
|
|
--- gcc-4.6-20120120-orig/configure 2011-12-18 20:03:44.000000000 +1000
|
|
+++ gcc-4.6-20120120/configure 2012-02-03 17:55:14.885990135 +1000
|
|
@@ -6049,8 +6049,8 @@
|
|
LDFLAGS="${_cloog_saved_LDFLAGS} ${clooglibs} ${ppllibs}"
|
|
|
|
if test "${cloog_org}" = yes ; then
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.1 of CLooG" >&5
|
|
-$as_echo_n "checking for version 0.16.1 of CLooG... " >&6; }
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.17 of CLooG" >&5
|
|
+$as_echo_n "checking for version 0.17 of CLooG... " >&6; }
|
|
if test "${gcc_cv_cloog_ct_0_14_0+set}" = set; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
@@ -6061,8 +6061,7 @@
|
|
main ()
|
|
{
|
|
#if CLOOG_VERSION_MAJOR != 0 \
|
|
- || CLOOG_VERSION_MINOR != 16 \
|
|
- || CLOOG_VERSION_REVISION < 1
|
|
+ || CLOOG_VERSION_MINOR != 17
|
|
choke me
|
|
#endif
|
|
;
|
|
diff -Naur gcc-4.6-20120120-orig/gcc/graphite-clast-to-gimple.c gcc-4.6-20120120/gcc/graphite-clast-to-gimple.c
|
|
--- gcc-4.6-20120120-orig/gcc/graphite-clast-to-gimple.c 2011-03-13 08:05:38.000000000 +1000
|
|
+++ gcc-4.6-20120120/gcc/graphite-clast-to-gimple.c 2012-02-03 17:51:47.943463879 +1000
|
|
@@ -1367,7 +1367,7 @@
|
|
/* Change cloog output language to C. If we do use FORTRAN instead, cloog
|
|
will stop e.g. with "ERROR: unbounded loops not allowed in FORTRAN.", if
|
|
we pass an incomplete program to cloog. */
|
|
- options->language = LANGUAGE_C;
|
|
+ options->language = CLOOG_LANGUAGE_C;
|
|
|
|
/* Enable complex equality spreading: removes dummy statements
|
|
(assignments) in the generated code which repeats the
|