mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
30 lines
923 B
Diff
30 lines
923 B
Diff
From cc2bf49fc88e52aae8464f8c9876855cb1ab21dd Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Thu, 7 Sep 2017 12:50:39 -0600
|
|
Subject: [PATCH] disable pie
|
|
|
|
---
|
|
Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index ed83376624f..6217f927d55 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -374,11 +374,11 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
|
|
-Werror-implicit-function-declaration \
|
|
-Wno-format-security \
|
|
-fno-delete-null-pointer-checks \
|
|
- -std=gnu89
|
|
+ -std=gnu89 $(call cc-option,-fno-PIE)
|
|
|
|
KBUILD_AFLAGS_KERNEL :=
|
|
KBUILD_CFLAGS_KERNEL :=
|
|
-KBUILD_AFLAGS := -D__ASSEMBLY__
|
|
+KBUILD_AFLAGS := -D__ASSEMBLY__ $(call cc-option,-fno-PIE)
|
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
|
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
|
--
|
|
2.14.1
|
|
|