mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
20 lines
890 B
Diff
20 lines
890 B
Diff
See ICU change https://github.com/unicode-org/icu/commit/2e45e6ec0e84a1c01812015a254ea31b286316fb
|
|
|
|
Similar has happened in the past. See:
|
|
https://chromium.googlesource.com/chromium/src/+/e60b571faa3f14dd9119a6792dccf12f8bf80192
|
|
|
|
diff --git a/third_party/blink/renderer/platform/text/text_break_iterator.cc b/third_party/blink/renderer/platform/text/text_break_iterator.cc
|
|
index ddfbd51..247da06 100644
|
|
--- a/third_party/blink/renderer/platform/text/text_break_iterator.cc
|
|
+++ b/third_party/blink/renderer/platform/text/text_break_iterator.cc
|
|
@@ -161,7 +161,9 @@ static const unsigned char kAsciiLineBreakTable[][(kAsciiLineBreakTableLastChar
|
|
};
|
|
// clang-format on
|
|
|
|
-#if U_ICU_VERSION_MAJOR_NUM >= 58
|
|
+#if U_ICU_VERSION_MAJOR_NUM >= 74
|
|
+#define BA_LB_COUNT (U_LB_COUNT - 8)
|
|
+#elif U_ICU_VERSION_MAJOR_NUM >= 58
|
|
#define BA_LB_COUNT (U_LB_COUNT - 3)
|
|
#else
|
|
#define BA_LB_COUNT U_LB_COUNT
|