mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
45 lines
2 KiB
Diff
45 lines
2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Thu, 6 May 2021 20:14:58 +0200
|
|
Subject: [PATCH] bootstrap: Change libexec dir
|
|
|
|
---
|
|
src/bootstrap/dist.rs | 4 ++--
|
|
src/bootstrap/tool.rs | 2 +-
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
|
index 6594b23c56b0..2e6a96ba4d79 100644
|
|
--- a/src/bootstrap/dist.rs
|
|
+++ b/src/bootstrap/dist.rs
|
|
@@ -404,7 +404,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
|
target: compiler.host,
|
|
})
|
|
.expect("rust-analyzer-proc-macro-server always builds");
|
|
- builder.install(&ra_proc_macro_srv, &image.join("libexec"), 0o755);
|
|
+ builder.install(&ra_proc_macro_srv, &image.join("lib"), 0o755);
|
|
|
|
let libdir_relative = builder.libdir_relative(compiler);
|
|
|
|
@@ -1047,7 +1047,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
|
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
|
let dirent = dirent.expect("read dir entry");
|
|
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
|
- tarball.add_file(&dirent.path(), "libexec", 0o755);
|
|
+ tarball.add_file(&dirent.path(), "lib", 0o755);
|
|
}
|
|
}
|
|
|
|
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
|
|
index 9a2100c2fb78..d51b1ff8449e 100644
|
|
--- a/src/bootstrap/tool.rs
|
|
+++ b/src/bootstrap/tool.rs
|
|
@@ -792,7 +792,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
|
|
|
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
|
// so that r-a can use it.
|
|
- let libexec_path = builder.sysroot(self.compiler).join("libexec");
|
|
+ let libexec_path = builder.sysroot(self.compiler).join("lib");
|
|
t!(fs::create_dir_all(&libexec_path));
|
|
builder.copy(&path, &libexec_path.join("rust-analyzer-proc-macro-srv"));
|
|
|