mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
139 lines
5.9 KiB
Diff
139 lines
5.9 KiB
Diff
http://bugs.gentoo.org/198817
|
||
|
||
from upstream gnulib for "extern inline" changes
|
||
|
||
diff --git a/lib/argp-fmtstream.h b/lib/argp-fmtstream.h
|
||
index 93fa651..50f1387 100644
|
||
--- a/lib/argp-fmtstream.h
|
||
+++ b/lib/argp-fmtstream.h
|
||
@@ -1,5 +1,5 @@
|
||
/* Word-wrapping and line-truncating streams.
|
||
- Copyright (C) 1997, 2006 Free Software Foundation, Inc.
|
||
+ Copyright (C) 1997, 2006-2007 Free Software Foundation, Inc.
|
||
This file is part of the GNU C Library.
|
||
Written by Miles Bader <miles@gnu.ai.mit.edu>.
|
||
|
||
@@ -134,6 +134,7 @@ extern ssize_t argp_fmtstream_printf (argp_fmtstream_t __fs,
|
||
const char *__fmt, ...)
|
||
__attribute__ ((__format__ (printf, 2, 3)));
|
||
|
||
+#if _LIBC || !defined __OPTIMIZE__
|
||
extern int __argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
|
||
extern int argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
|
||
|
||
@@ -144,6 +145,7 @@ extern size_t __argp_fmtstream_write (argp_fmtstream_t __fs,
|
||
const char *__str, size_t __len);
|
||
extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
|
||
const char *__str, size_t __len);
|
||
+#endif
|
||
|
||
/* Access macros for various bits of state. */
|
||
#define argp_fmtstream_lmargin(__fs) ((__fs)->lmargin)
|
||
@@ -153,6 +155,7 @@ extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
|
||
#define __argp_fmtstream_rmargin argp_fmtstream_rmargin
|
||
#define __argp_fmtstream_wmargin argp_fmtstream_wmargin
|
||
|
||
+#if _LIBC || !defined __OPTIMIZE__
|
||
/* Set __FS's left margin to LMARGIN and return the old value. */
|
||
extern size_t argp_fmtstream_set_lmargin (argp_fmtstream_t __fs,
|
||
size_t __lmargin);
|
||
@@ -174,6 +177,7 @@ extern size_t __argp_fmtstream_set_wmargin (argp_fmtstream_t __fs,
|
||
/* Return the column number of the current output point in __FS. */
|
||
extern size_t argp_fmtstream_point (argp_fmtstream_t __fs);
|
||
extern size_t __argp_fmtstream_point (argp_fmtstream_t __fs);
|
||
+#endif
|
||
|
||
/* Internal routines. */
|
||
extern void _argp_fmtstream_update (argp_fmtstream_t __fs);
|
||
@@ -197,7 +201,28 @@ extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
|
||
#endif
|
||
|
||
#ifndef ARGP_FS_EI
|
||
-#define ARGP_FS_EI extern inline
|
||
+# ifdef __GNUC__
|
||
+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
|
||
+ inline semantics, unless -fgnu89-inline is used. It defines a macro
|
||
+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
|
||
+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
|
||
+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
|
||
+ semantics but warns, unless -fgnu89-inline is used:
|
||
+ warning: C99 inline functions are not supported; using GNU89
|
||
+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
|
||
+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
|
||
+# if defined __GNUC_STDC_INLINE__
|
||
+# define ARGP_FS_EI inline
|
||
+# elif defined __GNUC_GNU_INLINE__
|
||
+# define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
|
||
+# else
|
||
+# define ARGP_FS_EI extern inline
|
||
+# endif
|
||
+# else
|
||
+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
|
||
+ the compiler supports 'inline' at all. */
|
||
+# define ARGP_FS_EI inline
|
||
+# endif
|
||
#endif
|
||
|
||
ARGP_FS_EI size_t
|
||
diff --git a/lib/argp.h b/lib/argp.h
|
||
index fb11de6..aa76eb4 100644
|
||
--- a/lib/argp.h
|
||
+++ b/lib/argp.h
|
||
@@ -520,9 +520,11 @@ extern void __argp_state_help (const struct argp_state *__restrict __state,
|
||
FILE *__restrict __stream,
|
||
unsigned int __flags);
|
||
|
||
+#if _LIBC || !defined __USE_EXTERN_INLINES
|
||
/* Possibly output the standard usage message for ARGP to stderr and exit. */
|
||
extern void argp_usage (const struct argp_state *__state);
|
||
extern void __argp_usage (const struct argp_state *__state);
|
||
+#endif
|
||
|
||
/* If appropriate, print the printf string FMT and following args, preceded
|
||
by the program name and `:', to stderr, and followed by a `Try ... --help'
|
||
@@ -551,6 +553,7 @@ extern void __argp_failure (const struct argp_state *__restrict __state,
|
||
const char *__restrict __fmt, ...)
|
||
__attribute__ ((__format__ (__printf__, 4, 5)));
|
||
|
||
+#if _LIBC || !defined __USE_EXTERN_INLINES
|
||
/* Returns true if the option OPT is a valid short option. */
|
||
extern int _option_is_short (const struct argp_option *__opt) __THROW;
|
||
extern int __option_is_short (const struct argp_option *__opt) __THROW;
|
||
@@ -559,6 +562,7 @@ extern int __option_is_short (const struct argp_option *__opt) __THROW;
|
||
options array. */
|
||
extern int _option_is_end (const struct argp_option *__opt) __THROW;
|
||
extern int __option_is_end (const struct argp_option *__opt) __THROW;
|
||
+#endif
|
||
|
||
/* Return the input field for ARGP in the parser corresponding to STATE; used
|
||
by the help routines. */
|
||
@@ -579,7 +583,28 @@ extern void *__argp_input (const struct argp *__restrict __argp,
|
||
# endif
|
||
|
||
# ifndef ARGP_EI
|
||
-# define ARGP_EI extern __inline__
|
||
+# ifdef __GNUC__
|
||
+ /* GCC 4.3 and above with -std=c99 or -std=gnu99 implements ISO C99
|
||
+ inline semantics, unless -fgnu89-inline is used. It defines a macro
|
||
+ __GNUC_STDC_INLINE__ to indicate this situation or a macro
|
||
+ __GNUC_GNU_INLINE__ to indicate the opposite situation.
|
||
+ GCC 4.2 with -std=c99 or -std=gnu99 implements the GNU C inline
|
||
+ semantics but warns, unless -fgnu89-inline is used:
|
||
+ warning: C99 inline functions are not supported; using GNU89
|
||
+ warning: to disable this warning use -fgnu89-inline or the gnu_inline function attribute
|
||
+ It defines a macro __GNUC_GNU_INLINE__ to indicate this situation. */
|
||
+# if defined __GNUC_STDC_INLINE__
|
||
+# define ARGP_EI __inline__
|
||
+# elif defined __GNUC_GNU_INLINE__
|
||
+# define ARGP_EI extern __inline__ __attribute__ ((__gnu_inline__))
|
||
+# else
|
||
+# define ARGP_EI extern __inline__
|
||
+# endif
|
||
+# else
|
||
+ /* With other compilers, assume the ISO C99 meaning of 'inline', if
|
||
+ the compiler supports 'inline' at all. */
|
||
+# define ARGP_EI inline
|
||
+# endif
|
||
# endif
|
||
|
||
ARGP_EI void
|